[packages] usbutils: Do not automatically update USB IDs on real system
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Apr 2011 17:40:16 +0000 (17:40 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Apr 2011 17:40:16 +0000 (17:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26650 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/usbutils/Makefile

index 033e5de..fef5bfe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
 PKG_VERSION:=002
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/usb/usbutils
@@ -29,6 +29,7 @@ endef
 
 define Package/usbutils/postinst
 #!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] || \
 (cd $${IPKG_INSTROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-usbids.sh ; rm usb.ids.gz.old)
 exit 0
 endef