tctool: include unistd.h for close()
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Mar 2014 16:52:10 +0000 (16:52 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Mar 2014 16:52:10 +0000 (16:52 +0000)
We were failing the build due to a missing prototype for close().

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39921 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tctool/Makefile
net/tctool/patches/001_Makefile_fix.diff
net/tctool/patches/005-fix-gcc_4_3-compile.patch
net/tctool/patches/006-fix_close_declaration.patch [new file with mode: 0644]

index 36a5087..68e801c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tctool
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=http://download2.berlios.de/speedmodem50b
index ee7c4f5..8677c4e 100644 (file)
@@ -1,7 +1,6 @@
-diff -ur tctool.old/src/Makefile tctool/src/Makefile
---- tctool.old/src/Makefile    2007-01-03 02:32:24.000000000 +0100
-+++ tctool/src/Makefile        2007-09-18 19:15:03.068155702 +0200
-@@ -31,16 +31,16 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -31,16 +31,16 @@ MAINOBJ  := if.o interface.o etherStream
  EXAMPLE  := example
  EXOBJ    := if.o interface.o etherStream.o etherStreambuf.o tcStream.o tcStreambuf.o tcRtsDump.o tcRtsDumpbuf.o
  
index 76008b9..3abe592 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/src/tctool.cpp b/src/tctool.cpp
-index bbab13f..9ce8e5c 100644
 --- a/src/tctool.cpp
 +++ b/src/tctool.cpp
 @@ -33,6 +33,7 @@
diff --git a/net/tctool/patches/006-fix_close_declaration.patch b/net/tctool/patches/006-fix_close_declaration.patch
new file mode 100644 (file)
index 0000000..387b474
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/etherStreambuf.cpp
++++ b/src/etherStreambuf.cpp
+@@ -28,6 +28,7 @@
+ #include "etherStreambuf.h"
+ #include <stdio.h>
++#include <unistd.h>
+ namespace tc {
+    etherStreambuf::etherStreambuf() {
+--- a/src/tcStreambuf.cpp
++++ b/src/tcStreambuf.cpp
+@@ -30,6 +30,7 @@
+ // this is for the udp-part...
+ #include <netdb.h>         // gethostbyname hostent
+ #include <arpa/inet.h>     // inet_ntoa
++#include <unistd.h>
+ namespace tc {
+    char tcStreambuf::tcPktType::confirmation(char pktType) {