ntripclient: pass our CFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:19 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:19 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39817 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ntripclient/Makefile

index baf5177..d36e8a6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntripclient
 PKG_VERSION:=1.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME).zip
 PKG_SOURCE_URL:=http://igs.bkg.bund.de/root_ftp/NTRIP/software/
@@ -36,6 +36,9 @@ define Build/Prepare
        unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
 endef
 
+MAKE_FLAGS += \
+       OPTS="$(TARGET_CFLAGS)"
+
 define Package/ntripclient/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntripclient $(1)/usr/bin/