[packages] php5: prepare pecl macros to distinguish between normal and zend extensions
authormhei <mhei@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Apr 2014 20:26:10 +0000 (20:26 +0000)
committermhei <mhei@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Apr 2014 20:26:10 +0000 (20:26 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40389 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/pecl.mk

index 6bf1928..e1b9819 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -37,7 +37,11 @@ define PECLPackage
        $(INSTALL_DIR) $$(1)/usr/lib/php
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/modules/$(subst -,_,$(1)).so $$(1)/usr/lib/php/
        $(INSTALL_DIR) $$(1)/etc/php5
+    ifeq ($(4),zend)
+       echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php5/$(subst -,_,$(1)).ini
+    else
        echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php5/$(subst -,_,$(1)).ini
+    endif
   endef
 
 endef