libdbi-drivers: pass our CFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Mar 2014 17:14:39 +0000 (17:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Mar 2014 17:14:39 +0000 (17:14 +0000)
The configure script would always force some CFLAGS based on what it detected
remove that as it is completely bogus.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39942 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libdbi-drivers/Makefile
libs/libdbi-drivers/patches/001-configure_cflags_override.patch [new file with mode: 0644]

index 8b5304f..f546b47 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdbi-drivers
 PKG_VERSION:=0.8.3-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/libdbi-drivers
diff --git a/libs/libdbi-drivers/patches/001-configure_cflags_override.patch b/libs/libdbi-drivers/patches/001-configure_cflags_override.patch
new file mode 100644 (file)
index 0000000..a96fbba
--- /dev/null
@@ -0,0 +1,46 @@
+--- a/configure.in
++++ b/configure.in
+@@ -34,43 +34,6 @@ dnl ====================================
+ dnl Set some general compile options
+ dnl ====================================
+-if test -z "$GCC"; then
+-        case $host in
+-        *-*-irix*)
+-                if test -z "$CC"; then
+-                        CC=cc
+-                fi
+-                DEBUG="-g -signed"
+-                CFLAGS="-O2 -w -signed"
+-                PROFILE="-p -g3 -O2 -signed" ;;
+-        sparc-sun-solaris*)
+-                DEBUG="-v -g"
+-                CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
+-                PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
+-        *)
+-                DEBUG="-g"
+-                CFLAGS="-O"
+-                PROFILE="-g -p" ;;
+-        esac
+-else
+-
+-        case $host in
+-        *-*-linux*)
+-                DEBUG="-g -Wall -D_REENTRANT -D__NO_MATH_INLINES -fsigned-char"
+-                CFLAGS="-O20 -ffast-math -D_REENTRANT -fsigned-char"
+-                PROFILE="-pg -g -O20 -ffast-math -D_REENTRANT -fsigned-char";;
+-        sparc-sun-*)
+-                DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -mv8"
+-                CFLAGS="-O20 -ffast-math -D__NO_MATH_INLINES -fsigned-char -mv8"
+-                PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8" ;;
+-        *)
+-                DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
+-                CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
+-                PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
+-        esac
+-fi
+-
+-
+ AC_SUBST(DEBUG)
+ AC_SUBST(PROFILE)