[packages] imlib2: Pass Xorg include and libarary path. Otherwise it will look
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Feb 2010 21:02:40 +0000 (21:02 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Feb 2010 21:02:40 +0000 (21:02 +0000)
for it for them in the host environment.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19804 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/imlib2/Makefile

index 607ee53..87e55b8 100644 (file)
@@ -30,7 +30,15 @@ define Package/imlib2
   DEPENDS:=+libX11 +giflib +libtiff +libjpeg +gtk1 +libfreetype +libXext
 endef
 
-CONFIGURE_ARGS+=--disable-gtktest LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
+TARGET_CFLAGS += "-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --x-includes="$(STAGING_DIR)/usr/include/X11" \
+               --x-libraries="$(STAGING_DIR)/usr/lib/" \
+               --disable-gtktest \
+       )
+endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{include,lib/pkgconfig}