bridge-utils: fix a struct in6_addr reference
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 16:16:43 +0000 (16:16 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 16:16:43 +0000 (16:16 +0000)
Bridge-utils uses kernel headers.  Linux 3.8 has a header,
include/uapi/linux/if_bridge.h that uses a struct in6_addr but
doesn't define it.  The trivial seeming fix of including the header
that does define it causes more problems.  The problem was discussed
on mailing lists in January 2013.  The final suggestion I found was
here:

  http://www.redhat.com/archives/libvir-list/2013-January/msg01253.html

This is intended to implement that suggestion.

Signed-off-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35999 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/bridge-utils/Makefile
net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch [new file with mode: 0644]

index f87551c..63edf4a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=@SF/bridge
 PKG_VERSION:=1.5
 PKG_MD5SUM:=ec7b381160b340648dede58c31bb2238
diff --git a/net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch b/net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch
new file mode 100644 (file)
index 0000000..c2087e5
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/libbridge/libbridge.h
++++ b/libbridge/libbridge.h
+@@ -20,6 +20,7 @@
+ #define _LIBBRIDGE_H
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <linux/if.h>
+ #include <linux/if_bridge.h>