[Packages] utils/gnupg: Update to 1.4.9
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Apr 2008 10:28:35 +0000 (10:28 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Apr 2008 10:28:35 +0000 (10:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10974 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/gnupg/Makefile
utils/gnupg/patches/001-no_po_and_docs.patch [deleted file]

index a49a061..3036671 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.7
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=b06a141cca5cd1a55bbdd25ab833303c
+PKG_MD5SUM:=cc52393087480ac8d245625004a6a30c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,9 +32,9 @@ define Package/gnupg/description
  It can be used to encrypt data and to create digital signatures.
  It includes an advanced key management facility and is compliant
  with the proposed OpenPGP Internet standard as described in RFC2440.
+ .
  GnuPG does not use any patented algorithms so it cannot be compatible
- with PGP2 because it uses IDEA (which is patented worldwide). 
+ with PGP2 because it uses IDEA (which is patented worldwide).
 endef
 
 CONFIGURE_ARGS += \
@@ -53,6 +53,9 @@ CONFIGURE_ARGS += \
        --enable-fake-curl \
        --disable-regex \
 
+MAKE_FLAGS += \
+       SUBDIRS="m4 intl zlib util mpi cipher tools g10 keyserver ${checks}" \
+
 define Package/gnupg/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
diff --git a/utils/gnupg/patches/001-no_po_and_docs.patch b/utils/gnupg/patches/001-no_po_and_docs.patch
deleted file mode 100644 (file)
index e649499..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: gnupg-1.4.7/Makefile.in
-===================================================================
---- gnupg-1.4.7.orig/Makefile.in       2007-09-07 18:53:42.000000000 +0200
-+++ gnupg-1.4.7/Makefile.in    2007-09-07 18:53:42.000000000 +0200
-@@ -311,7 +311,7 @@
- AUTOMAKE_OPTIONS = dist-bzip2 filename-length-max=99
- @CROSS_COMPILING_FALSE@checks = checks
- @CROSS_COMPILING_TRUE@checks = 
--SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver po doc ${checks}
-+SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver ${checks}
- EXTRA_DIST = scripts/config.rpath  PROJECTS BUGS config.h.in autogen.sh
- DISTCLEANFILES = 
- all: config.h