gnutls: Allow gnutls to be compiled using nettle-mini.
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 May 2014 00:57:40 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 May 2014 00:57:40 +0000 (00:57 +0000)
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40723 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gnutls/Makefile

index c2a010a..997532b 100644 (file)
@@ -75,7 +75,7 @@ endef
 define Package/libgnutls
 $(call Package/gnutls/Default)
   TITLE+= (library)
-  DEPENDS+= +libnettle
+  DEPENDS+= +libnettle +!LIBNETTLE_MINI:libgmp
 endef
 
 define Package/libgnutls/description
@@ -110,6 +110,10 @@ CONFIGURE_ARGS+= \
        --disable-crywrap \
        --without-p11-kit
 
+ifeq ($(CONFIG_LIBNETTLE_MINI),y)
+CONFIGURE_ARGS += --with-nettle-mini
+endif
+
 ifneq ($(CONFIG_GNUTLS_DTLS_SRTP),y)
 CONFIGURE_ARGS += --disable-dtls-srtp-support
 endif