Let libol-config return paths relative to $(STAGING_DIR).
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:40:43 +0000 (16:40 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:40:43 +0000 (16:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12914 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libol/Makefile

index f47f66f..b0a2b30 100644 (file)
@@ -48,6 +48,9 @@ define Build/InstallDev
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/libol-config \
                $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/libol-config
 
        $(INSTALL_DIR) $(1)/usr/include/libol
        $(INSTALL_DATA) \