[packages] ahcpd: cope with empty flag options
authorkerneis <kerneis@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jun 2011 07:30:21 +0000 (07:30 +0000)
committerkerneis <kerneis@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jun 2011 07:30:21 +0000 (07:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27303 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcp.sh

index 1a1f4df..b417c60 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
 PKG_VERSION:=0.51
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index e909def..805013c 100644 (file)
@@ -3,7 +3,7 @@ append_bool() {
        local option="$2"
        local value="$3"
        local _loctmp
-       config_get_bool _loctmp "$section" "$option"
+       config_get_bool _loctmp "$section" "$option" 0
        [ "$_loctmp" -gt 0 ] && append args "$value"
 }