perf: make cleaning non-fatal if $(PKG_BUILD_DIR) does not exist
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jan 2013 16:34:36 +0000 (16:34 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jan 2013 16:34:36 +0000 (16:34 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35235 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/perf/Makefile

index bd51fa5..c4dad1f 100644 (file)
@@ -37,7 +37,8 @@ endef
 # MAKE_FLAGS should be passed again upon cleaning because Perf's makefile
 # always performs checks before processing any rule
 define Build/Clean
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       -$(MAKE) -C $(PKG_BUILD_DIR) \
+               NO_DWARF=1 \
                $(MAKE_FLAGS) \
                clean
 endef