patch: moved to github
[packages.git] / devel / patch / Makefile
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
deleted file mode 100644 (file)
index 1300855..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2008-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=patch
-PKG_VERSION:=2.5.9
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/patch
-PKG_MD5SUM:=dacfb618082f8d3a2194601193cf8716
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/patch
-  SECTION:=devel
-  CATEGORY:=Development
-  TITLE:=patch
-  URL:=http://www.gnu.org/
-endef
-
-define Package/patch/description
-  The Patch package contains a program for modifying or creating files
-  by applying a "patch" file typically created by the diff program.
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               exec_prefix="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/patch/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,patch))