mdk3: fix compile on platforms with VFP
[packages.git] / net / tinc / Makefile
index bb256cb..646c906 100644 (file)
@@ -1,55 +1,59 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.23
 PKG_RELEASE:=1
-PKG_MD5SUM:=63887373dd763f8d90cecc5a3616c363
 
-PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
-       http://ftp.yi.se/pub/tinc/ \
-       http://www.mirrors.wiretapped.net/security/network-security/tinc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages
+PKG_MD5SUM:=762c0d47bdf1b33a40b19165d9c2761f
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +zlib
+  DEPENDS:=+liblzo +libopenssl +kmod-tun
   TITLE:=VPN tunneling daemon
-  DESCRIPTION:=A VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
+  SUBMENU:=VPN
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--with-kernel=$(LINUX_DIR) \
-                 --with-zlib=$(STAGING_DIR)/usr/ \
-                 --with-lzo-include=$(STAGING_DIR)/usr/include/lzo \
-)
+define Package/tinc/description
+  tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and
+  encryption to create a secure private network between hosts on the Internet.
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
+TARGET_CFLAGS += -std=gnu99
+
+CONFIGURE_ARGS += \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-zlib="$(STAGING_DIR)/usr" \
+       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo"
+
+define Package/tinc/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/tinc
+       $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
+       $(INSTALL_DATA) files/tinc.upgrade $(1)/lib/upgrade/keep.d/tinc
 endef
 
-define Package/tinc/install    
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
+define Package/tinc/conffiles
+/etc/config/tinc
 endef
 
 $(eval $(call BuildPackage,tinc))