install headers and library
authorFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2012 18:09:41 +0000 (19:09 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2012 18:09:41 +0000 (19:09 +0100)
CMakeLists.txt

index bd8ce3f..640afce 100644 (file)
@@ -25,3 +25,11 @@ ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
 
 SET(CMAKE_INSTALL_PREFIX /usr)
 TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
 
 SET(CMAKE_INSTALL_PREFIX /usr)
+
+FILE(GLOB headers *.h)
+INSTALL(FILES ${headers}
+       DESTINATION include/libubox
+)
+INSTALL(TARGETS ustream-ssl
+       LIBRARY DESTINATION lib
+)