initial dummy
authorFelix Fietkau <nbd@openwrt.org>
Sun, 26 May 2013 14:31:50 +0000 (16:31 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 26 May 2013 14:31:50 +0000 (16:31 +0200)
.gitignore [new file with mode: 0644]
CMakeLists.txt [new file with mode: 0644]
main.c [new file with mode: 0644]

diff --git a/.gitignore b/.gitignore
new file mode 100644 (file)
index 0000000..0c4ef2c
--- /dev/null
@@ -0,0 +1,7 @@
+usbmode
+.*
+Makefile
+CMakeCache.txt
+CMakeFiles
+*.cmake
+install_manifest.txt
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644 (file)
index 0000000..17914a7
--- /dev/null
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(usbmode C)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+SET(SOURCES main.c)
+SET(LIBS ubox blobmsg_json)
+
+IF(DEBUG)
+  ADD_DEFINITIONS(-DDEBUG -g3)
+ENDIF()
+
+ADD_EXECUTABLE(usbmode ${SOURCES})
+TARGET_LINK_LIBRARIES(usbmode ${LIBS})
+
+INSTALL(TARGETS usbmode
+       RUNTIME DESTINATION sbin
+)
diff --git a/main.c b/main.c
new file mode 100644 (file)
index 0000000..3fed7e6
--- /dev/null
+++ b/main.c
@@ -0,0 +1,6 @@
+#include <stdio.h>
+
+int main(int argc, char **argv)
+{
+       return 0;
+}