uci: fix Lua finding
authorYegor Yefremov <yegorslists@googlemail.com>
Sun, 6 Apr 2014 19:41:32 +0000 (21:41 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 6 Apr 2014 20:48:44 +0000 (22:48 +0200)
If ${LUAPATH} is not quoted and Lua is not provided, then following
error occurs:

"NOT" "No such file or directory" "EQUAL" "0" "OR" "EQUAL" ""

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
lua/CMakeLists.txt

index e4295d7..4ba8e37 100644 (file)
@@ -36,7 +36,7 @@ IF(NOT LUAPATH)
        )
 
        IF(BUILD_LUA)
        )
 
        IF(BUILD_LUA)
-               IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR ${LUAPATH} EQUAL "")
+               IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR "${LUAPATH}" EQUAL "")
                        MESSAGE(SEND_ERROR "Lua was not found on your system")
                ENDIF()
        ENDIF()
                        MESSAGE(SEND_ERROR "Lua was not found on your system")
                ENDIF()
        ENDIF()