fold err.h into uci_internal.h
authorFelix Fietkau <nbd@openwrt.org>
Tue, 12 Feb 2008 11:19:11 +0000 (12:19 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 12 Feb 2008 11:19:11 +0000 (12:19 +0100)
Makefile
err.h [deleted file]
libuci.c
uci_internal.h

index 8f1371d..7ac2385 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,7 @@ else
 endif
 SHLIB_FILE=libuci.$(SHLIB_EXT).$(VERSION)
 
 endif
 SHLIB_FILE=libuci.$(SHLIB_EXT).$(VERSION)
 
-LIBUCI_DEPS=file.c history.c list.c util.c err.h uci.h
+LIBUCI_DEPS=file.c history.c list.c util.c uci.h uci_internal.h
 
 all: uci-static uci libuci.$(SHLIB_EXT)
 
 
 all: uci-static uci libuci.$(SHLIB_EXT)
 
diff --git a/err.h b/err.h
deleted file mode 100644 (file)
index e8b977b..0000000
--- a/err.h
+++ /dev/null
@@ -1,100 +0,0 @@
-/*
- * libuci - Library for the Unified Configuration Interface
- * Copyright (C) 2008 Felix Fietkau <nbd@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU Lesser General Public License version 2.1
- * as published by the Free Software Foundation
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- */
-
-/*
- * functions for debug and error handling, for internal use only
- */
-
-#ifdef UCI_DEBUG
-#define DPRINTF(...) fprintf(stderr, __VA_ARGS__)
-#else
-#define DPRINTF(...)
-#endif
-
-/* 
- * throw an uci exception and store the error number
- * in the context.
- */
-#define UCI_THROW(ctx, err) do {       \
-       DPRINTF("Exception: %s in %s, %s:%d\n", #err, __func__, __FILE__, __LINE__); \
-       longjmp(ctx->trap, err);        \
-} while (0)
-
-/*
- * store the return address for handling exceptions
- * needs to be called in every externally visible library function
- *
- * NB: this does not handle recursion at all. Calling externally visible
- * functions from other uci functions is only allowed at the end of the
- * calling function, or by wrapping the function call in UCI_TRAP_SAVE
- * and UCI_TRAP_RESTORE.
- */
-#define UCI_HANDLE_ERR(ctx) do {       \
-       DPRINTF("ENTER: %s\n", __func__); \
-       int __val = 0;                  \
-       ctx->errno = 0;                 \
-       if (!ctx)                       \
-               return UCI_ERR_INVAL;   \
-       if (!ctx->internal)             \
-               __val = setjmp(ctx->trap); \
-       ctx->internal = false;          \
-       if (__val) {                    \
-               DPRINTF("LEAVE: %s, ret=%d\n", __func__, __val); \
-               ctx->errno = __val;     \
-               return __val;           \
-       }                               \
-} while (0)
-
-/*
- * In a block enclosed by UCI_TRAP_SAVE and UCI_TRAP_RESTORE, all exceptions
- * are intercepted and redirected to the label specified in 'handler'
- * after UCI_TRAP_RESTORE, or when reaching the 'handler' label, the old
- * exception handler is restored
- */
-#define UCI_TRAP_SAVE(ctx, handler) do {   \
-       jmp_buf __old_trap;             \
-       int __val;                      \
-       memcpy(__old_trap, ctx->trap, sizeof(ctx->trap)); \
-       __val = setjmp(ctx->trap);      \
-       if (__val) {                    \
-               ctx->errno = __val;     \
-               memcpy(ctx->trap, __old_trap, sizeof(ctx->trap)); \
-               goto handler;           \
-       }
-#define UCI_TRAP_RESTORE(ctx)          \
-       memcpy(ctx->trap, __old_trap, sizeof(ctx->trap)); \
-} while(0)
-
-/**
- * UCI_INTERNAL: Do an internal call of a public API function
- * 
- * Sets Exception handling to passthrough mode.
- * Allows API functions to change behavior compared to public use
- */
-#define UCI_INTERNAL(func, ctx, ...) do { \
-       ctx->internal = true;           \
-       func(ctx, __VA_ARGS__);         \
-} while (0)
-
-/*
- * check the specified condition.
- * throw an invalid argument exception if it's false
- */
-#define UCI_ASSERT(ctx, expr) do {     \
-       if (!(expr)) {                  \
-               DPRINTF("[%s:%d] Assertion failed\n", __FILE__, __LINE__); \
-               UCI_THROW(ctx, UCI_ERR_INVAL);  \
-       }                               \
-} while (0)
-
index 50c17f9..04d9b90 100644 (file)
--- a/libuci.c
+++ b/libuci.c
@@ -23,7 +23,6 @@
 #include <stdlib.h>
 #include <stdio.h>
 #include "uci.h"
 #include <stdlib.h>
 #include <stdio.h>
 #include "uci.h"
-#include "err.h"
 
 static const char *uci_confdir = UCI_CONFDIR;
 static const char *uci_savedir = UCI_SAVEDIR;
 
 static const char *uci_confdir = UCI_CONFDIR;
 static const char *uci_savedir = UCI_SAVEDIR;
index 5b496ea..81f0226 100644 (file)
@@ -35,4 +35,90 @@ struct uci_parse_context
 static void uci_add_history(struct uci_context *ctx, struct uci_list *list, int cmd, char *section, char *option, char *value);
 static void uci_free_history(struct uci_history *h);
 
 static void uci_add_history(struct uci_context *ctx, struct uci_list *list, int cmd, char *section, char *option, char *value);
 static void uci_free_history(struct uci_history *h);
 
+/*
+ * functions for debug and error handling, for internal use only
+ */
+
+#ifdef UCI_DEBUG
+#define DPRINTF(...) fprintf(stderr, __VA_ARGS__)
+#else
+#define DPRINTF(...)
+#endif
+
+/* 
+ * throw an uci exception and store the error number
+ * in the context.
+ */
+#define UCI_THROW(ctx, err) do {       \
+       DPRINTF("Exception: %s in %s, %s:%d\n", #err, __func__, __FILE__, __LINE__); \
+       longjmp(ctx->trap, err);        \
+} while (0)
+
+/*
+ * store the return address for handling exceptions
+ * needs to be called in every externally visible library function
+ *
+ * NB: this does not handle recursion at all. Calling externally visible
+ * functions from other uci functions is only allowed at the end of the
+ * calling function, or by wrapping the function call in UCI_TRAP_SAVE
+ * and UCI_TRAP_RESTORE.
+ */
+#define UCI_HANDLE_ERR(ctx) do {       \
+       DPRINTF("ENTER: %s\n", __func__); \
+       int __val = 0;                  \
+       ctx->errno = 0;                 \
+       if (!ctx)                       \
+               return UCI_ERR_INVAL;   \
+       if (!ctx->internal)             \
+               __val = setjmp(ctx->trap); \
+       ctx->internal = false;          \
+       if (__val) {                    \
+               DPRINTF("LEAVE: %s, ret=%d\n", __func__, __val); \
+               ctx->errno = __val;     \
+               return __val;           \
+       }                               \
+} while (0)
+
+/*
+ * In a block enclosed by UCI_TRAP_SAVE and UCI_TRAP_RESTORE, all exceptions
+ * are intercepted and redirected to the label specified in 'handler'
+ * after UCI_TRAP_RESTORE, or when reaching the 'handler' label, the old
+ * exception handler is restored
+ */
+#define UCI_TRAP_SAVE(ctx, handler) do {   \
+       jmp_buf __old_trap;             \
+       int __val;                      \
+       memcpy(__old_trap, ctx->trap, sizeof(ctx->trap)); \
+       __val = setjmp(ctx->trap);      \
+       if (__val) {                    \
+               ctx->errno = __val;     \
+               memcpy(ctx->trap, __old_trap, sizeof(ctx->trap)); \
+               goto handler;           \
+       }
+#define UCI_TRAP_RESTORE(ctx)          \
+       memcpy(ctx->trap, __old_trap, sizeof(ctx->trap)); \
+} while(0)
+
+/**
+ * UCI_INTERNAL: Do an internal call of a public API function
+ * 
+ * Sets Exception handling to passthrough mode.
+ * Allows API functions to change behavior compared to public use
+ */
+#define UCI_INTERNAL(func, ctx, ...) do { \
+       ctx->internal = true;           \
+       func(ctx, __VA_ARGS__);         \
+} while (0)
+
+/*
+ * check the specified condition.
+ * throw an invalid argument exception if it's false
+ */
+#define UCI_ASSERT(ctx, expr) do {     \
+       if (!(expr)) {                  \
+               DPRINTF("[%s:%d] Assertion failed\n", __FILE__, __LINE__); \
+               UCI_THROW(ctx, UCI_ERR_INVAL);  \
+       }                               \
+} while (0)
+
 #endif
 #endif