make building examples an option
authorThomas Gstädtner <thomas@gstaedtner.net>
Sun, 3 Mar 2013 02:06:19 +0000 (03:06 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Mar 2013 02:43:06 +0000 (03:43 +0100)
CMakeLists.txt
examples/CMakeLists.txt

index e6b8b86..1634b9b 100644 (file)
@@ -4,6 +4,7 @@ PROJECT(ubus C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 
 OPTION(BUILD_LUA "build Lua plugin" ON)
+OPTION(BUILD_EXAMPLES "build examples" ON)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
index 5a11a9f..df7350c 100644 (file)
@@ -2,9 +2,10 @@ cmake_minimum_required(VERSION 2.6)
 
 ADD_DEFINITIONS(-I..)
 
-ADD_EXECUTABLE(server server.c)
-TARGET_LINK_LIBRARIES(server ubus ubox blobmsg_json)
-
-ADD_EXECUTABLE(client client.c)
-TARGET_LINK_LIBRARIES(client ubus ubox)
+IF (BUILD_EXAMPLES)
+       ADD_EXECUTABLE(server server.c)
+       TARGET_LINK_LIBRARIES(server ubus ubox blobmsg_json)
 
+       ADD_EXECUTABLE(client client.c)
+       TARGET_LINK_LIBRARIES(client ubus ubox)
+ENDIF()