Make build of upgraded optional
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 16:05:46 +0000 (17:05 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 16:05:46 +0000 (17:05 +0100)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
CMakeLists.txt

index 92907fc..5414677 100644 (file)
@@ -26,7 +26,9 @@ IF(ZRAM_TMPFS)
   SET(SOURCES_ZRAM initd/zram.c)
 ENDIF()
 
   SET(SOURCES_ZRAM initd/zram.c)
 ENDIF()
 
-add_subdirectory(upgraded)
+IF(BUILD_UPGRADED)
+  add_subdirectory(upgraded)
+ENDIF()
 
 ADD_EXECUTABLE(procd ${SOURCES})
 TARGET_LINK_LIBRARIES(procd ${LIBS})
 
 ADD_EXECUTABLE(procd ${SOURCES})
 TARGET_LINK_LIBRARIES(procd ${LIBS})