add option to disable build of the init binary
authorFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 10:54:55 +0000 (11:54 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 10:54:55 +0000 (11:54 +0100)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
CMakeLists.txt

index 3219240..7299d9c 100644 (file)
@@ -47,13 +47,14 @@ INSTALL(TARGETS procd
        RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
 )
 
-
+IF(NOT DISABLE_INIT)
 ADD_EXECUTABLE(init initd/init.c initd/early.c initd/preinit.c initd/mkdev.c watchdog.c
        utils/utils.c ${SOURCES_ZRAM})
 TARGET_LINK_LIBRARIES(init ${LIBS})
 INSTALL(TARGETS init
        RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
 )
+ENDIF()
 
 
 ADD_EXECUTABLE(udevtrigger plug/udevtrigger.c)