* applications/luci-splash: Minor bugfixes
authorSteven Barth <steven@midlink.org>
Thu, 8 May 2008 20:59:08 +0000 (20:59 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 8 May 2008 20:59:08 +0000 (20:59 +0000)
applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
contrib/package/ffluci/Makefile

index 3bff85e..341aaa4 100644 (file)
@@ -8,7 +8,7 @@ require("ffluci.model.uci")
 
 local srv
 local net
-local ip = ffluci.http.remote_addr()
+local ip = ffluci.http.env.REMOTE_ADDR
 for k, v in pairs(ffluci.model.uci.sections("network")) do
        if v[".type"] == "interface" and v.ipaddr then
                local p = ffluci.sys.net.mask4prefix(v.netmask)
@@ -28,7 +28,7 @@ for k, v in pairs(ffluci.model.uci.sections("luci_splash")) do
 end
 
 if not srv then
-       ffluci.http.textheader()
+       ffluci.http.prepare_content("text/plain")
        return print("Unable to detect network settings!")
 end
 
index 8b51e97..f0f43db 100644 (file)
@@ -154,6 +154,7 @@ define Package/ffluci-app-splash/install
        $(call Package/ffluci/install/template,$(1),applications/luci-splash)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/sbin/luci-splash $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/init.d/luci_splash $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi $(1)/usr/lib/luci-splash/htdocs/cgi-bin
 endef