* Fixed cross compiling
authorSteven Barth <steven@midlink.org>
Thu, 12 Jun 2008 08:45:05 +0000 (08:45 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 12 Jun 2008 08:45:05 +0000 (08:45 +0000)
contrib/package/luci/Makefile
libs/sgi-webuci/Makefile

index af662f8..a059d0c 100644 (file)
@@ -450,7 +450,9 @@ ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
 endif
 
 
-MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" LDFLAGS="$(TARGET_LDFLAGS)"
+MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" \
+CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" LDFLAGS="$(TARGET_LDFLAGS)" \
+CFOPTS="$(TARGET_CONFIGURE_OPTS)"
 
 
 $(eval $(call BuildPackage,luci-core))
index 656db03..6758a2c 100644 (file)
@@ -32,7 +32,7 @@ $(BOA_DIR)/.patched: $(BOA_DIR)/.prepared $(BOA_PATCHDIR)/series
        touch $@
 
 $(BOA_DIR)/.configured: $(BOA_DIR)/.patched
-       (cd $(BOA_DIR); ./configure --disable-debug --disable-gunzip) 
+       (cd $(BOA_DIR); ./configure --disable-debug --disable-gunzip $(CFOPTS)
        touch $@
 
 boa-compile: $(BOA_DIR)/.configured