luci-app-adblock: backport the package from master
authorHannu Nyman <hannu.nyman@iki.fi>
Wed, 16 Mar 2016 14:15:24 +0000 (16:15 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Wed, 16 Mar 2016 14:15:24 +0000 (16:15 +0200)
Backport the luci-app-adblock package from master.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
applications/luci-app-adblock/Makefile [new file with mode: 0644]
applications/luci-app-adblock/luasrc/controller/adblock.lua [new file with mode: 0644]
applications/luci-app-adblock/luasrc/model/cbi/adblock.lua [new file with mode: 0644]
applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock [new file with mode: 0755]

diff --git a/applications/luci-app-adblock/Makefile b/applications/luci-app-adblock/Makefile
new file mode 100644 (file)
index 0000000..8efe2d6
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2016 Openwrt.org
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=LuCI support for Adblock
+LUCI_DEPENDS:=+adblock
+LUCI_PKGARCH:=all
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-adblock/luasrc/controller/adblock.lua b/applications/luci-app-adblock/luasrc/controller/adblock.lua
new file mode 100644 (file)
index 0000000..d8b4718
--- /dev/null
@@ -0,0 +1,12 @@
+-- Copyright 2016 Openwrt.org
+-- Licensed to the public under the Apache License 2.0.
+
+module("luci.controller.adblock", package.seeall)
+
+function index()
+       if not nixio.fs.access("/etc/config/adblock") then
+               return
+       end
+
+       entry({"admin", "services", "adblock"}, cbi("adblock"), _("Adblock"), 40)
+end
diff --git a/applications/luci-app-adblock/luasrc/model/cbi/adblock.lua b/applications/luci-app-adblock/luasrc/model/cbi/adblock.lua
new file mode 100644 (file)
index 0000000..2603617
--- /dev/null
@@ -0,0 +1,90 @@
+-- Copyright 2016 Openwrt.org
+-- Licensed to the public under the Apache License 2.0.
+
+m = Map("adblock", translate("Adblock"),
+       translate("Configuration of the adblock package to block ad/abuse domains by using DNS."))
+
+-- General options
+
+s = m:section(NamedSection, "global", "adblock", translate("Global options"))
+
+o1 = s:option(Flag, "adb_enabled", translate("Enable adblock"))
+o1.rmempty = false
+o1.default = 0
+
+o2 = s:option(Value, "adb_blacklist", translate("Blacklist file"),
+     translate("File with explicitly blacklisted hosts/domains."))
+o2.rmempty = false
+o2.datatype = "file"
+
+o3 = s:option(Value, "adb_whitelist", translate("Whitelist file"),
+     translate("File with whitelisted hosts/domains that are allowed despite being on a blocklist."))
+o3.rmempty = false
+o3.datatype = "file"
+
+fdns = s:option(Flag, "adb_forcedns", translate("Redirect all DNS queries to the local resolver"),
+        translate("When adblock is active, all DNS queries are redirected to the local resolver " ..
+        "in this server by default. You can disable that to allow queries to external DNS servers."))
+fdns.rmempty = false
+fdns.default = fdns.enabled
+
+-- Blocklist options
+
+bl = m:section(TypedSection, "source", translate("Blocklist sources"),
+       translate("Available blocklist sources (")
+       .. [[<a href="https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md" target="_blank">]]
+       .. translate("see list details")
+       .. [[</a>]]
+       .. translate("). Note that list URLs and Shallalist category selections are not configurable via Luci."))
+bl.template = "cbi/tblsection"
+
+name = bl:option(Flag, "enabled", translate("Enabled"))
+name.rmempty  = false
+
+des = bl:option(DummyValue, "adb_srcdesc", translate("Description"))
+des.rmempty  = false
+
+-- Additional options
+
+s2 = m:section(NamedSection, "backup", "service", translate("Backup options"))
+
+o4 = s2:option(Flag, "enabled", translate("Enable blocklist backup"))
+o4.rmempty = false
+o4.default = 0
+
+o5 = s2:option(Value, "adb_backupdir", translate("Backup directory"))
+o5.rmempty = false
+o5.datatype = "directory"
+
+-- Extra options
+
+e = m:section(NamedSection, "global", "adblock", translate("Extra options"),
+       translate("Options for further tweaking in case the defaults are not suitable for you."))
+
+a1 = e:option(Value, "adb_port", translate("Port of the adblock uhttpd instance"))
+a1.optional = true
+a1.default = 65535
+a1.datatype = "port"
+
+a2 = e:option(Value, "adb_nullipv4", translate("IPv4 blackhole ip address"))
+a2.optional = true
+a2.default = "192.0.2.1"
+a2.datatype = "ip4addr"
+
+a3 = e:option(Value, "adb_nullipv6", translate("IPv6 blackhole ip address"))
+a3.optional = true
+a3.default = "::ffff:c000:0201"
+a3.datatype = "ip6addr"
+
+a6 = e:option(Value, "adb_wanif", translate("Name of the logical wan interface"))
+a6.optional = true
+a6.default = "wan"
+a6.datatype = "network"
+
+a7 = e:option(Value, "adb_lanif", translate("Name of the logical lan interface"))
+a7.optional = true
+a7.default = "lan"
+a7.datatype = "network"
+
+return m
+
diff --git a/applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock b/applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock
new file mode 100755 (executable)
index 0000000..1f7fb1c
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+       delete ucitrack.@adblock[-1]
+       add ucitrack adblock
+       set ucitrack.@adblock[-1].init=adblock
+       commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0