Fix config files getting overwritten in opkg install
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 10 Dec 2016 09:20:01 +0000 (11:20 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Sat, 10 Dec 2016 09:20:01 +0000 (11:20 +0200)
Commit 39ff053890 accidentally removed the conffiles definitions
from luci-base, statistics, splash and diag-devinfo apps.

That has caused existing config files to get overwritten if the
package has been reinstalled via opkg. Additionally, the splash
text files have not been saved in sysupgrade or backup as they
are located outside /etc/config

This commit adds back the conffiles definitions to the respective
packages.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
applications/luci-app-diag-devinfo/Makefile
applications/luci-app-splash/Makefile
applications/luci-app-statistics/Makefile
modules/luci-base/Makefile

index 0424fff..1505b62 100644 (file)
@@ -9,6 +9,10 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI Diagnostics Tools (Device Info)
 LUCI_DEPENDS:=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo @BROKEN
 
 LUCI_TITLE:=LuCI Diagnostics Tools (Device Info)
 LUCI_DEPENDS:=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo @BROKEN
 
+define Package/luci-app-diag-devinfo/conffiles
+/etc/config/luci_devinfo
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 345f891..5740aa5 100644 (file)
@@ -9,6 +9,12 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Freifunk DHCP-Splash application
 LUCI_DEPENDS:=+luci-lib-nixio +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
 
 LUCI_TITLE:=Freifunk DHCP-Splash application
 LUCI_DEPENDS:=+luci-lib-nixio +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
 
+define Package/luci-app-splash/conffiles
+/etc/config/luci_splash
+/usr/lib/luci-splash/splashtext.html
+/usr/lib/luci-splash/splashtextinclude.html
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 6c0121e..008792a 100644 (file)
@@ -12,6 +12,10 @@ LUCI_DEPENDS:= \
        +collectd-mod-cpu +collectd-mod-memory \
        +collectd-mod-interface +collectd-mod-load +collectd-mod-network
 
        +collectd-mod-cpu +collectd-mod-memory \
        +collectd-mod-interface +collectd-mod-load +collectd-mod-network
 
+define Package/luci-app-statistics/conffiles
+/etc/config/luci_statistics
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 972a451..ce7d40d 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Package/luci-base/conffiles
 /etc/luci-uploads
 
 define Package/luci-base/conffiles
 /etc/luci-uploads
+/etc/config/luci
 endef
 
 include ../../luci.mk
 endef
 
 include ../../luci.mk