contrib/luaposix: Updated to 5.1.3
authorSteven Barth <steven@midlink.org>
Thu, 17 Jul 2008 21:58:53 +0000 (21:58 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 17 Jul 2008 21:58:53 +0000 (21:58 +0000)
contrib/luaposix/Makefile
contrib/luaposix/patches/100-darwin_compile.patch [deleted file]
contrib/luaposix/patches/200-crypt.patch

index c357f5d..a72db3c 100644 (file)
@@ -1,8 +1,8 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-LUAPOSIX_VERSION = 5.1.2
-LUAPOSIX_SITE = http://luaforge.net/frs/download.php/3063/
+LUAPOSIX_VERSION = 5.1.3
+LUAPOSIX_SITE = http://luaforge.net/frs/download.php/3449/
 LUAPOSIX_DIR = luaposix-$(LUAPOSIX_VERSION)
 LUAPOSIX_FILE = $(LUAPOSIX_DIR).tar.gz
 LUAPOSIX_URL = $(LUAPOSIX_SITE)/$(LUAPOSIX_FILE)
diff --git a/contrib/luaposix/patches/100-darwin_compile.patch b/contrib/luaposix/patches/100-darwin_compile.patch
deleted file mode 100644 (file)
index 07943ac..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: luaposix-5.1.2/Makefile
-===================================================================
---- luaposix-5.1.2.orig/Makefile       2008-01-29 14:49:27.000000000 +0100
-+++ luaposix-5.1.2/Makefile    2008-05-28 14:15:30.000000000 +0200
-@@ -34,6 +34,13 @@
- T=            $(MYLIB).so
-+OS=$(shell uname)
-+ifeq ($(OS),Darwin)
-+  LDFLAGS_SHARED=-bundle -undefined dynamic_lookup
-+else
-+  LDFLAGS_SHARED=-shared
-+endif
-+
- # targets
- phony += all
- all:  $T
-@@ -43,7 +50,7 @@
-       $(LUA) test.lua
- $T:   $(OBJS)
--      $(CC) $(LDFLAGS) -o $@ -shared $(OBJS)
-+      $(CC) $(LDFLAGS) -o $@ $(LDFLAGS_SHARED) $(OBJS)
- $(OBJS): modemuncher.c
index e90f310..6ceab55 100644 (file)
@@ -1,8 +1,6 @@
-Index: luaposix-5.1.2/lposix.c
-===================================================================
---- luaposix-5.1.2.orig/lposix.c       2008-06-02 17:35:21.000000000 +0200
-+++ luaposix-5.1.2/lposix.c    2008-06-02 17:35:26.000000000 +0200
-@@ -1006,6 +1006,29 @@
+--- a/lposix.c
++++ b/lposix.c
+@@ -1016,6 +1016,29 @@
  }
  #endif
  
@@ -32,7 +30,7 @@ Index: luaposix-5.1.2/lposix.c
  static const luaL_reg R[] =
  {
        {"access",              Paccess},
-@@ -1013,6 +1036,7 @@
+@@ -1023,6 +1046,7 @@
        {"chdir",               Pchdir},
        {"chmod",               Pchmod},
        {"chown",               Pchown},
@@ -40,10 +38,8 @@ Index: luaposix-5.1.2/lposix.c
        {"ctermid",             Pctermid},
        {"dirname",             Pdirname},
        {"dir",                 Pdir},
-Index: luaposix-5.1.2/Makefile
-===================================================================
---- luaposix-5.1.2.orig/Makefile       2008-06-02 17:35:26.000000000 +0200
-+++ luaposix-5.1.2/Makefile    2008-06-02 17:35:18.000000000 +0200
+--- a/Makefile
++++ b/Makefile
 @@ -37,8 +37,10 @@
  OS=$(shell uname)
  ifeq ($(OS),Darwin)