Merge pull request #1194 from TDT-GmbH/add-license-tags
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 20 Jun 2017 13:40:48 +0000 (16:40 +0300)
committerGitHub <noreply@github.com>
Tue, 20 Jun 2017 13:40:48 +0000 (16:40 +0300)
Add license tags

15 files changed:
applications/luci-app-commands/Makefile
applications/luci-app-firewall/Makefile
applications/luci-app-qos/Makefile
collections/luci-ssl/Makefile
collections/luci/Makefile
libs/luci-lib-ip/Makefile
libs/luci-lib-json/Makefile
libs/luci-lib-nixio/Makefile
libs/luci-lib-px5g/Makefile
modules/luci-base/Makefile
modules/luci-mod-admin-full/Makefile
modules/luci-mod-rpc/Makefile
protocols/luci-proto-ipv6/Makefile
protocols/luci-proto-ppp/Makefile
themes/luci-theme-bootstrap/Makefile

index dc5d0ca..f41d6e2 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI Shell Command Module
 LUCI_DEPENDS:=
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 21804d7..4fa85f2 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Firewall and Portforwarding application
 LUCI_DEPENDS:=+firewall
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index dd322a3..fd12557 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Quality of Service configuration module
 LUCI_DEPENDS:=+qos-scripts
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 8fb8ff4..399c982 100644 (file)
@@ -12,6 +12,8 @@ LUCI_BASENAME:=ssl
 LUCI_TITLE:=LuCI with HTTPS support (mbedTLS as SSL backend)
 LUCI_DEPENDS:=+luci +libustream-mbedtls +px5g
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 4625c95..6f6c3a9 100644 (file)
@@ -14,6 +14,8 @@ LUCI_DEPENDS:= \
        +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
        +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index eb80dcb..15cb537 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Lua library for IP calculation and routing information
 LUCI_DEPENDS:=+liblua +libnl-tiny
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 069886d..ededc1f 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI JSON library
 LUCI_DEPENDS:=
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 41800fe..bec5f83 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=NIXIO POSIX library
 LUCI_DEPENDS:=+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl +liblua
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 70b95e8..eefee10 100644 (file)
@@ -10,6 +10,7 @@ LUCI_TITLE:=RSA/X.509 Key Generator (required for LuCId SSL support)
 LUCI_DEPENDS:=+liblua
 
 PKG_USE_MIPS16:=0
+PKG_LICENSE:=LGPL-2.1
 
 include ../../luci.mk
 
index 753ff25..cc57ce8 100644 (file)
@@ -17,6 +17,7 @@ LUCI_DEPENDS:=+lua +libuci-lua +luci-lib-nixio +luci-lib-ip +rpcd +libubus-lua +
 PKG_SOURCE:=LuaSrcDiet-0.12.1.tar.bz2
 PKG_SOURCE_URL:=https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/luasrcdiet
 PKG_MD5SUM:=ed7680f2896269ae8633756e7edcf09050812f78c8f49e280e63c30d14f35aea
+PKG_LICENSE:=Apache-2.0
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/LuaSrcDiet-0.12.1
 
index 5fed279..36ddf13 100644 (file)
@@ -10,6 +10,7 @@ LUCI_TITLE:=LuCI Administration - full-featured for full control
 LUCI_DEPENDS:=+luci-base
 
 PKG_BUILD_DEPENDS:=iwinfo
+PKG_LICENSE:=Apache-2.0
 
 include ../../luci.mk
 
index e64c86c..bc1f6d2 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI RPC - JSON-RPC API
 LUCI_DEPENDS:=+luci-lib-json
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index e749bc9..761ee2f 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Support for DHCPv6/6in4/6to4/6rd/DS-Lite/aiccu
 LUCI_DEPENDS:=
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 70db744..dd1859e 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Support for PPP/PPPoE/PPPoA/PPtP
 LUCI_DEPENDS:=
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index c4e684e..1bb205e 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Bootstrap Theme (default)
 LUCI_DEPENDS:=
 
+PKG_LICENSE:=Apache-2.0
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature