contrib/meshwizard: Allow setting of luci_splash general values
authorManuel Munz <freifunk@somakoma.de>
Fri, 25 Nov 2011 16:18:43 +0000 (16:18 +0000)
committerManuel Munz <freifunk@somakoma.de>
Fri, 25 Nov 2011 16:18:43 +0000 (16:18 +0000)
contrib/package/meshwizard/Makefile
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/read_defaults.sh
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_splash.sh

index ffb1911..8cebf17 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meshwizard
-PKG_RELEASE:=0.0.5
+PKG_RELEASE:=0.0.6
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 69fd48b..f5b4943 100755 (executable)
@@ -15,7 +15,7 @@ for v in system wifi_device wifi_iface interface alias dhcp olsr_interface olsr_
 done
 
 # now read all values from the selected community profile, will override some values from the defaults before
-for v in system wifi_device wifi_iface interface alias dhcp olsr_interface olsr_interfacedefaults profile zone_freifunk include; do
+for v in system wifi_device wifi_iface interface alias dhcp olsr_interface olsr_interfacedefaults profile zone_freifunk include luci_splash; do
        get_var profile_$community.$v
 done
 
index 95b765a..b6106de 100755 (executable)
@@ -11,6 +11,9 @@ if [ ! "$has_luci_splash" == TRUE ]; then
        exit
 fi
 
+set_defaults "luci_splash_" luci_splash.general
+uci_commitverbose "Setup general splash settings" luci_splash
+
 dhcprange=$(uci -q get meshwizard.netconfig.$net\_dhcprange)
 
 if [ "$(uci -q get meshwizard.netconfig.$net\_dhcp)" == 1 ] && [ -n "$dhcprange" ]; then