fix bogus quilt patch apply errors
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2008 00:06:26 +0000 (00:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2008 00:06:26 +0000 (00:06 +0000)
libs/sgi-webuci/Makefile

index c679710..c7f70eb 100644 (file)
@@ -24,7 +24,7 @@ $(BOA_DIR)/.prepared: $(BOA_FILE)
 $(BOA_DIR)/.patched: $(BOA_DIR)/.prepared $(BOA_PATCHDIR)/series
        (cd $(BOA_DIR); \
                if [ -x "$$(which quilt 2>/dev/null)" ]; then \
-                       quilt push -a; \
+                       [ "$$(quilt top 2>/dev/null)" = "$$(tail -n1 patches/series)" ] || quilt push -a; \
                else \
                        cat patches/*.patch | patch -p1; \
                fi; \