contrib/package: remote-update: now expect "openwrt-atheros-combined.img" since we...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Oct 2009 12:17:41 +0000 (12:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Oct 2009 12:17:41 +0000 (12:17 +0000)
contrib/package/remote-update/Makefile
contrib/package/remote-update/files/usr/sbin/remote-update

index dd73d2f..f4affb4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=remote-update
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index e9a0a98..4fa7e38 100755 (executable)
@@ -19,16 +19,10 @@ find_image()
 {
        case "$1" in
                atheros)
-                       if grep -q '"vmlinux.bin.l7"' /proc/mtd; then
-                               echo "openwrt-fonera-combined.img"
-                       else
-                               echo "openwrt-ubiquity-combined.img"
-                       fi
+                       echo "openwrt-atheros-combined.img"
                ;;
                ar71xx)
-                       if grep -q '"kernel"' /proc/mtd; then
-                               echo "openwrt-ar71xx-combined.img"
-                       fi
+                       echo "openwrt-ar71xx-combined.img"
                ;;
                brcm-2.4)
                        echo "openwrt-brcm-2.4-squashfs.trx"