Fix SDK build process
authorSteven Barth <steven@midlink.org>
Sat, 20 Jun 2009 07:20:56 +0000 (07:20 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 20 Jun 2009 07:20:56 +0000 (07:20 +0000)
Makefile
build/lucid.lua [new file with mode: 0644]
contrib/lar/Makefile

index d082a98..1343884 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -50,15 +50,8 @@ hostenv: host ucidefaults
 ucidefaults:
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
 
-runboa: hostenv
-       libs/sgi-webuci/host/buildconfig.sh $(realpath host) > host/etc/boa/boa.conf
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/boa) -c $(realpath host/etc/boa) -d"
-
 runhttpd: hostenv
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/lucittpd) $(realpath host)/usr/lib/lucittpd/plugins"
-
-runluci: luahost
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath libs/httpd/host/runluci) $(realpath host) $(HTDOCS)"
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua build/lucid.lua"
 
 runlua: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua -i build/setup.lua"
diff --git a/build/lucid.lua b/build/lucid.lua
new file mode 100644 (file)
index 0000000..71e4fd2
--- /dev/null
@@ -0,0 +1,2 @@
+dofile "build/setup.lua"
+require "luci.lucid".start()
index cc328de..5199546 100644 (file)
@@ -5,6 +5,7 @@ LDFLAGS :=
 OBJ = cli.o lar.o md5.o
 BIN = lar
 
+compile:
 cli: $(OBJ)
        $(GCC) $(CFLAGS) -o $(BIN) $(OBJ) $(LDFLAGS)