luci-app-advanced-reboot & luci-app-vpnbypass: fix uci require for master 1733/head
authorStan Grishin <stangri@melmac.net>
Sat, 7 Apr 2018 11:14:58 +0000 (04:14 -0700)
committerStan Grishin <stangri@melmac.net>
Sat, 7 Apr 2018 11:14:58 +0000 (04:14 -0700)
Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-advanced-reboot/README.md
applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po
applications/luci-app-vpnbypass/Makefile
applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua
applications/luci-app-vpnbypass/po/pt-br/vpnbypass.po
applications/luci-app-vpnbypass/po/ru/vpnbypass.po
applications/luci-app-vpnbypass/po/zh-cn/vpnbypass.po
applications/luci-app-vpnbypass/po/zh-tw/vpnbypass.po

index bb545a2..d270498 100644 (file)
@@ -13,7 +13,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
 
 LUCI_DEPENDS:=+luci
 LUCI_PKGARCH:=all
 
 LUCI_DEPENDS:=+luci
 LUCI_PKGARCH:=all
-PKG_RELEASE:=26
+PKG_RELEASE:=27
 
 include ../../luci.mk
 
 
 include ../../luci.mk
 
index a938479..d4659c8 100644 (file)
@@ -19,7 +19,7 @@ Currently supported dual-partition devices include:
 If you're interested in having your device supported, please post in [LEDE Project Forum Support Thread](https://forum.lede-project.org/t/web-ui-to-reboot-to-another-partition-dual-partition-routers/3423).
 
 ## Screenshot (luci-app-advanced-reboot)
 If you're interested in having your device supported, please post in [LEDE Project Forum Support Thread](https://forum.lede-project.org/t/web-ui-to-reboot-to-another-partition-dual-partition-routers/3423).
 
 ## Screenshot (luci-app-advanced-reboot)
-![screenshot](https://raw.githubusercontent.com/stangri/screenshots/master/luci-app-advanced-reboot/screenshot01.png "screenshot")
+![screenshot](https://raw.githubusercontent.com/stangri/openwrt_packages/master/screenshots/luci-app-advanced-reboot/screenshot01.png "screenshot")
 
 ## How to install
 Install ```luci-app-advanced-reboot``` from Web UI or connect to your router via ssh and run the following commands:
 
 ## How to install
 Install ```luci-app-advanced-reboot``` from Web UI or connect to your router via ssh and run the following commands:
index 0f512df..8c54052 100644 (file)
@@ -3,24 +3,27 @@
 
 module("luci.controller.advanced_reboot", package.seeall)
 
 
 module("luci.controller.advanced_reboot", package.seeall)
 
+uci = require "uci"
+
 -- device_name, board_name, part1, part2, offset, env_var_1, value_1_1, value_1_2, env_var_2, value_2_1, value_2_2
 devices = {
   {"Linksys EA3500", "linksys-audi", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys E4200v2/EA4500", "linksys-viper", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys EA8500", "ea8500", "mtd13", "mtd15", 32, "boot_part", 1, 2},
 -- device_name, board_name, part1, part2, offset, env_var_1, value_1_1, value_1_2, env_var_2, value_2_1, value_2_2
 devices = {
   {"Linksys EA3500", "linksys-audi", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys E4200v2/EA4500", "linksys-viper", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys EA8500", "ea8500", "mtd13", "mtd15", 32, "boot_part", 1, 2},
-  {"Linksys WRT1200AC", "armada-385-linksys-caiman", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
-  {"Linksys WRT1900AC", "armada-xp-linksys-mamba", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
-  {"Linksys WRT1900ACv2", "armada-385-linksys-cobra", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
-  {"Linksys WRT1900ACS", "armada-385-linksys-shelby", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
-  {"Linksys WRT3200ACM", "armada-385-linksys-rango", "mtd5", "mtd7", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+--  {"Linksys EA9500", "linksys,panamera", "mtd3", "mtd6", 28, "boot_part", 1, 2},
+  {"Linksys WRT1200AC", "linksys-caiman", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+  {"Linksys WRT1900AC", "linksys-mamba", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+  {"Linksys WRT1900ACv2", "linksys-cobra", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+  {"Linksys WRT1900ACS", "linksys-shelby", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+  {"Linksys WRT3200ACM", "linksys-rango", "mtd5", "mtd7", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"ZyXEL NBG6817","nbg6817","mmcblk0p4","mmcblk0p7",32,nil,255,1}
 }
 
 errorMessage = ""
 device_board_name = luci.util.trim(luci.sys.exec("cat /tmp/sysinfo/board_name"))
 for i=1, #devices do
   {"ZyXEL NBG6817","nbg6817","mmcblk0p4","mmcblk0p7",32,nil,255,1}
 }
 
 errorMessage = ""
 device_board_name = luci.util.trim(luci.sys.exec("cat /tmp/sysinfo/board_name"))
 for i=1, #devices do
-  table_board_name = devices[i][2]:gsub('-','')
-  if device_board_name and device_board_name:gsub('-',''):match(table_board_name) then
+  table_board_name = devices[i][2]:gsub('%p','')
+  if device_board_name and device_board_name:gsub('%p',''):match(table_board_name) then
     device_name = devices[i][1]
     partition_one_mtd = devices[i][3] or nil
     partition_two_mtd = devices[i][4] or nil
     device_name = devices[i][1]
     partition_one_mtd = devices[i][3] or nil
     partition_two_mtd = devices[i][4] or nil
index be9d2d7..75d4636 100644 (file)
@@ -12,8 +12,6 @@ msgstr ""
 "Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
 "%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
 "Language: ru\n"
 "Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
 "%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
 "Language: ru\n"
-"Project-Info: Это технический перевод, не дословный. Главное-удобный русский "
-"интерфейс, все проверялось в графическом режиме, совместим с другими apps\n"
 
 msgid "Action"
 msgstr "Действие"
 
 msgid "Action"
 msgstr "Действие"
@@ -162,4 +160,4 @@ msgid "Warning: This system does not support powering off!"
 msgstr "Внимание: Эта система не поддерживает отключение питания!"
 
 msgid "to"
 msgstr "Внимание: Эта система не поддерживает отключение питания!"
 
 msgid "to"
-msgstr "к"
+msgstr ""
index 838840e..f426acc 100644 (file)
@@ -10,7 +10,7 @@ LUCI_TITLE:=VPN Bypass Web UI
 LUCI_DESCRIPTION:=Provides Web UI for VPNBypass service.
 LUCI_DEPENDS:=+luci +vpnbypass
 LUCI_PKGARCH:=all
 LUCI_DESCRIPTION:=Provides Web UI for VPNBypass service.
 LUCI_DEPENDS:=+luci +vpnbypass
 LUCI_PKGARCH:=all
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include ../../luci.mk
 
 
 include ../../luci.mk
 
index 9d2f5f4..18fbeaa 100644 (file)
@@ -1,5 +1,7 @@
 readmeURL = "https://github.com/openwrt/packages/blob/master/net/vpnbypass/files/README.md"
 
 readmeURL = "https://github.com/openwrt/packages/blob/master/net/vpnbypass/files/README.md"
 
+uci = require "uci"
+
 m = Map("vpnbypass", translate("VPN Bypass Settings"))
 s = m:section(NamedSection, "config", "vpnbypass")
 
 m = Map("vpnbypass", translate("VPN Bypass Settings"))
 s = m:section(NamedSection, "config", "vpnbypass")
 
index 4fa07f9..9f3fa2a 100644 (file)
@@ -18,6 +18,9 @@ msgstr "Domínios para evitar a VPN"
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr ""
 
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr ""
 
+msgid "Enable/start service"
+msgstr ""
+
 msgid "Local IP Addresses to Bypass"
 msgstr ""
 
 msgid "Local IP Addresses to Bypass"
 msgstr ""
 
@@ -49,9 +52,6 @@ msgstr "Portas remotas para evitar a VPN"
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "Portas remotas para disparar o VPN Bypass"
 
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "Portas remotas para disparar o VPN Bypass"
 
-msgid "Start VPNBypass service"
-msgstr ""
-
 msgid "VPN Bypass"
 msgstr "VPN Bypass"
 
 msgid "VPN Bypass"
 msgstr "VPN Bypass"
 
index 05e2193..96cbb3f 100644 (file)
@@ -21,6 +21,9 @@ msgstr "Домены, для<br />обхода блокировки"
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "Домены должны быть доступны напрямую (вне VPN-туннеля), см."
 
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "Домены должны быть доступны напрямую (вне VPN-туннеля), см."
 
+msgid "Enable/start service"
+msgstr "Включение / Запуск сервиса"
+
 msgid "Local IP Addresses to Bypass"
 msgstr "Локальный IP-адрес<br />обхода VPN"
 
 msgid "Local IP Addresses to Bypass"
 msgstr "Локальный IP-адрес<br />обхода VPN"
 
@@ -28,14 +31,14 @@ msgid ""
 "Local IP addresses or subnets with direct internet access (outside of the "
 "VPN tunnel)"
 msgstr ""
 "Local IP addresses or subnets with direct internet access (outside of the "
 "VPN tunnel)"
 msgstr ""
-"Ð\9bокалÑ\8cнÑ\8bе IP-адÑ\80еÑ\81а Ð¸Ð»Ð¸ Ð¿Ð¾Ð´Ñ\81еÑ\82и Ñ\81 Ð¿Ñ\80Ñ\8fмÑ\8bм Ð´Ð¾Ñ\81Ñ\82Ñ\83пом Ð² Ð\98нтернет (вне VPN-"
+"Ð\9bокалÑ\8cнÑ\8bе IP-адÑ\80еÑ\81а Ð¸Ð»Ð¸ Ð¿Ð¾Ð´Ñ\81еÑ\82и Ñ\81 Ð¿Ñ\80Ñ\8fмÑ\8bм Ð´Ð¾Ñ\81Ñ\82Ñ\83пом Ð² Ð¸нтернет (вне VPN-"
 "туннеля)."
 
 msgid "Local Ports to Bypass"
 "туннеля)."
 
 msgid "Local Ports to Bypass"
-msgstr "Локальные порты<br />для обхода VPN"
+msgstr "Локальные порты для запуска обхода VPN"
 
 msgid "Local ports to trigger VPN Bypass"
 
 msgid "Local ports to trigger VPN Bypass"
-msgstr "Локальные порты для запуска обхода VPN."
+msgstr "Локальные порты<br />для обхода VPN"
 
 msgid "README"
 msgstr "Описание"
 
 msgid "README"
 msgstr "Описание"
@@ -54,10 +57,7 @@ msgid "Remote Ports to Bypass"
 msgstr "Удаленные порты<br />для обхода VPN"
 
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "Удаленные порты<br />для обхода VPN"
 
 msgid "Remote ports to trigger VPN Bypass"
-msgstr "Удаленные порты для запуска обхода VPN."
-
-msgid "Start VPNBypass service"
-msgstr "Запуск сервиса VPNBypass"
+msgstr "Удаленные порты для запуска обхода VPN"
 
 msgid "VPN Bypass"
 msgstr "Обход VPN"
 
 msgid "VPN Bypass"
 msgstr "Обход VPN"
@@ -66,4 +66,4 @@ msgid "VPN Bypass Settings"
 msgstr "Настройка обхода VPN"
 
 msgid "for syntax"
 msgstr "Настройка обхода VPN"
 
 msgid "for syntax"
-msgstr "для синтаксиса."
+msgstr "для синтаксиса"
index 72c55a6..a153917 100644 (file)
@@ -17,6 +17,9 @@ msgstr "要绕过的域"
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "要直接访问的域(不使用 VPN 隧道),请参见"
 
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "要直接访问的域(不使用 VPN 隧道),请参见"
 
+msgid "Enable/start service"
+msgstr "启用/启动服务"
+
 msgid "Local IP Addresses to Bypass"
 msgstr "要绕过的本地 IP 地址"
 
 msgid "Local IP Addresses to Bypass"
 msgstr "要绕过的本地 IP 地址"
 
@@ -48,9 +51,6 @@ msgstr "要绕过的远程端口"
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "触发 VPN 绕过的远程端口"
 
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "触发 VPN 绕过的远程端口"
 
-msgid "Start VPNBypass service"
-msgstr ""
-
 msgid "VPN Bypass"
 msgstr "VPN 绕过"
 
 msgid "VPN Bypass"
 msgstr "VPN 绕过"
 
@@ -59,6 +59,3 @@ msgstr "VPN 绕过设置"
 
 msgid "for syntax"
 msgstr "对于语法"
 
 msgid "for syntax"
 msgstr "对于语法"
-
-#~ msgid "Enable/start service"
-#~ msgstr "启用/启动服务"
index 9eb3812..90ba85f 100644 (file)
@@ -17,6 +17,9 @@ msgstr "要繞過的域"
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "要直接訪問的域(不使用 VPN 隧道),請參見"
 
 msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
 msgstr "要直接訪問的域(不使用 VPN 隧道),請參見"
 
+msgid "Enable/start service"
+msgstr "啟用/啟動服務"
+
 msgid "Local IP Addresses to Bypass"
 msgstr "要繞過的本地 IP 位址"
 
 msgid "Local IP Addresses to Bypass"
 msgstr "要繞過的本地 IP 位址"
 
@@ -48,9 +51,6 @@ msgstr "要繞過的遠端埠"
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "觸發 VPN 繞過的遠端埠"
 
 msgid "Remote ports to trigger VPN Bypass"
 msgstr "觸發 VPN 繞過的遠端埠"
 
-msgid "Start VPNBypass service"
-msgstr ""
-
 msgid "VPN Bypass"
 msgstr "VPN 繞過"
 
 msgid "VPN Bypass"
 msgstr "VPN 繞過"
 
@@ -59,6 +59,3 @@ msgstr "VPN 繞過設定"
 
 msgid "for syntax"
 msgstr "對於語法"
 
 msgid "for syntax"
 msgstr "對於語法"
-
-#~ msgid "Enable/start service"
-#~ msgstr "啟用/啟動服務"