nixio: Update documentation to prepare 0.3 release
authorSteven Barth <steven@midlink.org>
Sat, 11 Jul 2009 07:54:57 +0000 (07:54 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 11 Jul 2009 07:54:57 +0000 (07:54 +0000)
libs/nixio/docsrc/CHANGELOG.lua [new file with mode: 0644]
libs/nixio/docsrc/README.lua
libs/nixio/docsrc/nixio.UnifiedIO.lua
libs/nixio/standalone.mk

diff --git a/libs/nixio/docsrc/CHANGELOG.lua b/libs/nixio/docsrc/CHANGELOG.lua
new file mode 100644 (file)
index 0000000..f73e966
--- /dev/null
@@ -0,0 +1,29 @@
+--- Changes and improvements.
+module "CHANGELOG"
+
+--- Nixio 0.3
+-- <ul>
+-- <li>Added getifaddrs() function.</li>
+-- <li>Added getsockopt(), setsockopt(), getsockname() and getpeername()
+-- directly to TLS-socket objects unifying the socket interface.</li>
+-- <li>Added support for CyaSSL as cryptographical backend.</li>
+-- <li>Added support for x509 certificates in DER format.</li>
+-- <li>Added support for splice() in UnifiedIO.copyz().</li>
+-- <li>Added interface to inject chunks into UnifiedIO.linesource() buffer.</li>
+-- <li>Changed TLS behaviour to explicitely separate servers and clients.</li>
+-- <li>Fixed usage of signed datatype breaking Base64 decoding.</li>
+-- <li>Fixed namespace clashes for nixio.fs.</li>
+-- <li>Fixed splice() support for some exotic C libraries.</li>
+-- <li>Reconfigure axTLS cryptographical provider.</li>
+-- </ul>
+-- @class table
+-- @name 0.2
+-- @return !
+
+--- Nixio 0.2
+-- <ul>
+-- <li>Initial Release</li>  
+-- </ul>
+-- @class table
+-- @name 0.2
+-- @return !
\ No newline at end of file
index 20793ce..b957a69 100644 (file)
@@ -80,15 +80,12 @@ module "README"
 
 --- Cryptography and TLS libraries.
 -- <ul>
--- <li>Currently 2 underlying cryptography libraries are supported: openssl and
--- axTLS. The name of the library in use is written to 
+-- <li>Currently 3 underlying cryptography libraries are supported: openssl,
+-- cyassl and axTLS. The name of the library in use is written to 
 -- <strong>nixio.tls_provider</strong></li>
--- <li>You should whenever possible use openssl as axTLS has only limited 
--- support. It does not provide support for non-blocking sockets and
--- is probably less audited than openssl.</li>
--- <li>However in embedded development if you don't need openssl anyway
--- you may safe an essential amount of flash space (about 1 MB for the openssl
--- library) by choosing axTLS over openssl.</li>
+-- <li>You should whenever possible use openssl or cyassl as axTLS has only 
+-- limited support. It does not provide support for non-blocking sockets and
+-- is probably less audited than the other ones.</li>
 -- <li>As the supported Windows versions are not suitable for embedded devices
 -- axTLS is at the moment not supported on Windows.</li>  
 -- </ul>
index d0b189c..6e407ff 100644 (file)
@@ -111,7 +111,6 @@ module "nixio.UnifiedIO"
 -- @usage This function uses the sendfile() syscall to copy the data or the
 -- blocksource function of the source descriptor and the sink function
 -- of the target descriptor as a fallback mechanism.
--- @usage Support for splice() on Linux is not implemented yet.
 -- @usage If the limit parameter is ommited, data is copied
 -- until an end-of-file, end-of-stream, connection shutdown or similar happens.
 -- @usage If the descriptor is non-blocking the function may fail with EAGAIN.
index fe71f58..95f6bec 100644 (file)
@@ -42,7 +42,6 @@ clean: luaclean
 
 luasource:
        mkdir -p dist$(LUA_MODULEDIR)
-       cp -pR root/* dist 2>/dev/null || true
        cp -pR lua/* dist$(LUA_MODULEDIR) 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm -rf $$i || true; done
 
@@ -53,4 +52,4 @@ luacompile: luasource
        for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
 
 luaclean:
-       rm -rf dist
\ No newline at end of file
+       rm -rf dist