Push luaposix to 5.1.4
authorSteven Barth <steven@midlink.org>
Thu, 25 Sep 2008 09:57:32 +0000 (09:57 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 25 Sep 2008 09:57:32 +0000 (09:57 +0000)
contrib/luaposix/.gitignore
contrib/luaposix/Makefile
contrib/luaposix/patches/200-crypt.patch [deleted file]

index c900421..1407d23 100644 (file)
@@ -1,2 +1,3 @@
 luaposix-*
+lua-posix_*
 patches/series
index a91138d..70d3c9c 100644 (file)
@@ -1,10 +1,10 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-LUAPOSIX_VERSION = 5.1.3
+LUAPOSIX_VERSION = 5.1.4
 LUAPOSIX_SITE = http://dev.luci.freifunk-halle.net/sources/
 LUAPOSIX_DIR = luaposix-$(LUAPOSIX_VERSION)
-LUAPOSIX_FILE = $(LUAPOSIX_DIR).tar.gz
+LUAPOSIX_FILE = lua-posix_5.1.4.orig.tar.gz
 LUAPOSIX_URL = $(LUAPOSIX_SITE)/$(LUAPOSIX_FILE)
 LUAPOSIX_PATCHDIR = patches
 
@@ -15,26 +15,12 @@ include ../../build/module.mk
 $(LUAPOSIX_FILE):
        wget -O $@ $(LUAPOSIX_URL) || rm -f $@
 
-$(LUAPOSIX_PATCHDIR)/series:
-       (cd $(LUAPOSIX_PATCHDIR); ls *.patch | sort > series)
-
 $(LUAPOSIX_DIR)/.prepared: $(LUAPOSIX_FILE)
        rm -rf $(LUAPOSIX_DIR)
        tar xvfz $(LUAPOSIX_FILE)
-       ln -s ../$(LUAPOSIX_PATCHDIR) $(LUAPOSIX_DIR)/patches
-       touch $@
-
-$(LUAPOSIX_DIR)/.patched: $(LUAPOSIX_DIR)/.prepared $(LUAPOSIX_PATCHDIR)/series
-       (cd $(LUAPOSIX_DIR); \
-               if [ -x "$$(which quilt 2>/dev/null)" ]; then \
-                       quilt push -a; \
-               else \
-                       cat patches/*.patch | patch -p1; \
-               fi; \
-       )
        touch $@
 
-compile: $(LUAPOSIX_DIR)/.patched
+compile: $(LUAPOSIX_DIR)/.prepared
        $(MAKE) -C $(LUAPOSIX_DIR) CC=$(CC) CFLAGS="$(CFLAGS) $(LUA_CFLAGS)" LDFLAGS="$(LDFLAGS) $(LUA_SHLIBS)" OS="$(OS)"
        mkdir -p dist$(LUA_LIBRARYDIR)
        cp $(LUAPOSIX_DIR)/posix.so dist$(LUA_LIBRARYDIR)
diff --git a/contrib/luaposix/patches/200-crypt.patch b/contrib/luaposix/patches/200-crypt.patch
deleted file mode 100644 (file)
index 6ceab55..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/lposix.c
-+++ b/lposix.c
-@@ -1016,6 +1016,29 @@
- }
- #endif
-+/*
-+ * XXX: GNU and BSD handle the forward declaration of crypt() in different
-+ * and annoying ways (especially GNU). Declare it here just to make sure
-+ * that it's there
-+ */
-+char *crypt(const char *, const char *);
-+
-+static int Pcrypt(lua_State *L)
-+{
-+      const char *str, *salt;
-+      char *res;
-+
-+      str = luaL_checkstring(L, 1);
-+      salt = luaL_checkstring(L, 2);
-+      if (strlen(salt) < 2)
-+              luaL_error(L, "not enough salt");
-+
-+      res = crypt(str, salt);
-+      lua_pushstring(L, res);
-+
-+      return 1;
-+}
-+
- static const luaL_reg R[] =
- {
-       {"access",              Paccess},
-@@ -1023,6 +1046,7 @@
-       {"chdir",               Pchdir},
-       {"chmod",               Pchmod},
-       {"chown",               Pchown},
-+      {"crypt",               Pcrypt},
-       {"ctermid",             Pctermid},
-       {"dirname",             Pdirname},
-       {"dir",                 Pdir},
---- a/Makefile
-+++ b/Makefile
-@@ -37,8 +37,10 @@
- OS=$(shell uname)
- ifeq ($(OS),Darwin)
-   LDFLAGS_SHARED=-bundle -undefined dynamic_lookup
-+  LIBS=
- else
-   LDFLAGS_SHARED=-shared
-+  LIBS=-lcrypt
- endif
- # targets
-@@ -50,7 +52,7 @@
-       $(LUA) test.lua
- $T:   $(OBJS)
--      $(CC) $(LDFLAGS) -o $@ $(LDFLAGS_SHARED) $(OBJS)
-+      $(CC) $(LDFLAGS) -o $@ $(LDFLAGS_SHARED) $(OBJS) $(LIBS)
- $(OBJS): modemuncher.c