luci-app-ddns: fix errors in global.lua 347/head
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Fri, 20 Mar 2015 08:06:11 +0000 (09:06 +0100)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Fri, 20 Mar 2015 08:06:11 +0000 (09:06 +0100)
fix dispatcher and validation errors in global.lua

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua

index f20b49e..1bffcaa 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.2.2
 
 # Release == build
 # increase on changes of translation files
index e171873..fbd3cb3 100644 (file)
@@ -35,6 +35,7 @@ local ns = m:section( NamedSection, "global", "ddns",
        .. [[<a href="http://wiki.openwrt.org/doc/uci/ddns#version_2x1" target="_blank">]]
        .. translate("For detailed information about parameter settings look here.")
        .. [[</a>]]
+       )
 
 -- section might not exist
 function ns.cfgvalue(self, section)
@@ -119,7 +120,6 @@ ll.title    = translate("Log length")
 ll.description = translate("Number of last lines stored in log files")
 ll.rmempty     = true
 ll.default     = "250"
-ll.datatype    = "and(uinteger,min(1))"
 function ll.validate(self, value)
        local n = tonumber(value)
        if not n or math.floor(n) ~= n or n < 1 then