luci-app-ddns: ignore if name lookup progs not supporting force ip version
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sun, 25 Sep 2016 08:53:13 +0000 (10:53 +0200)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sun, 25 Sep 2016 08:53:13 +0000 (10:53 +0200)
- no longer verify installed name lookup programs to set has_forceip flag inside tools/ddns.lua
- adapt messages inside hints.lua

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua
applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua
applications/luci-app-ddns/luasrc/tools/ddns.lua
applications/luci-app-ddns/po/de/ddns.po
applications/luci-app-ddns/po/templates/ddns.pot

index c1a22c8..55ce1cb 100644 (file)
@@ -10,11 +10,11 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.6
+PKG_VERSION:=2.4.7
 
 # Release == build
 # increase on changes of translation files
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
index 1f2e6f2..b5c725f 100755 (executable)
@@ -18,11 +18,11 @@ local UTIL = require "luci.util"
 local DDNS = require "luci.tools.ddns"         -- ddns multiused functions
 
 local srv_name    = "ddns-scripts"
-local srv_ver_min = "2.7.2"                    -- minimum version of service required
+local srv_ver_min = "2.7.4"                    -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.4.6-1"
+local app_version = "2.4.7-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
index 1f5ad68..21827b7 100644 (file)
@@ -116,9 +116,9 @@ if not DDNS.has_forceip then
                value = value .. "<br />- " ..
                        translate("You should install 'wget' or 'curl' or 'uclient-fetch' package.")
        end
-       if not (DDNS.has_bindhost or DDNS.has_hostip) then
+       if not DDNS.has_bindhost then
                value = value .. "<br />- " ..
-                       translate("You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package for DNS requests.")
+                       translate("You should install 'bind-host' or 'knot-host' or 'drill' package for DNS requests.")
        end
        fi.value = value
 end
index 6b626b9..e55c673 100755 (executable)
@@ -31,7 +31,7 @@ has_nslookup  = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"
 has_ipv6       = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
 has_ssl                = (has_wgetssl or has_curlssl or (has_fetch and has_fetchssl))
 has_proxy      = (has_wgetssl or has_curlpxy or has_fetch or has_bbwget)
-has_forceip    = ((has_wgetssl or has_curl or has_fetch) and (has_bindhost or has_hostip))
+has_forceip    = (has_wgetssl or has_curl or has_fetch) -- only really needed for transfer
 has_dnsserver  = (has_bindhost or has_hostip or has_nslookup)
 has_bindnet    = (has_wgetssl or has_curl)
 has_cacerts    = _check_certs()
index 517fe36..39c1fdc 100644 (file)
@@ -1,8 +1,8 @@
 msgid ""
 msgstr ""
 "Project-Id-Version: luci-app-ddns 2.4.2-1\n"
-"POT-Creation-Date: 2016-05-08 19:10+0200\n"
-"PO-Revision-Date: 2016-05-08 19:12+0200\n"
+"POT-Creation-Date: 2016-09-25 10:43+0200\n"
+"PO-Revision-Date: 2016-09-25 10:43+0200\n"
 "Last-Translator: Christian Schönebeck <christian.schoenebeck@gmail.com>\n"
 "Language-Team: \n"
 "Language: de\n"
@@ -670,13 +670,6 @@ msgstr ""
 "Systemprotokoll geschrieben."
 
 msgid ""
-"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package "
-"for DNS requests."
-msgstr ""
-"Sie sollten das Programmpakete 'bind-host' oder 'knot-host' oder 'drill' "
-"oder 'hostip' für DNS Anfragen installieren."
-
-msgid ""
 "You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
 "package, if you need to specify a DNS server to detect your registered IP."
 msgstr ""
index d134ea1..194bf81 100644 (file)
@@ -571,11 +571,6 @@ msgid ""
 msgstr ""
 
 msgid ""
-"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package "
-"for DNS requests."
-msgstr ""
-
-msgid ""
 "You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
 "package, if you need to specify a DNS server to detect your registered IP."
 msgstr ""