Optimized caching behaviour, automatically flush caches in dev environment
authorSteven Barth <steven@midlink.org>
Mon, 15 Sep 2008 16:49:56 +0000 (16:49 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 15 Sep 2008 16:49:56 +0000 (16:49 +0000)
Makefile
libs/core/luasrc/ccache.lua
libs/sgi-cgi/htdocs/cgi-bin/luci
libs/web/root/etc/config/luci

index c90f11f..acb6659 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ hostcopy:
        for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_MODULEDIR) host/luci
+       rm -rf /tmp/luci-* || true
 
 hostenv: host ucidefaults
 
index 437d385..83e82d9 100644 (file)
@@ -32,7 +32,7 @@ function cache_ondemand(...)
 end
 
 function cache_enable(cachepath, mode)
-       cachepath = cachepath or "/tmp/.luciccache"
+       cachepath = cachepath or "/tmp/luci-modulecache"
        mode = mode or "r--r--r--"
 
        local loader = package.loaders[2]
index cd9bb59..529d1d0 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/lua
 require "luci.cacheloader"
 require "luci.sgi.cgi"
-luci.dispatcher.indexcache = "/tmp/.luciindex"
+luci.dispatcher.indexcache = "/tmp/luci-indexcache"
 luci.sgi.cgi.run()
\ No newline at end of file
index f78fbb0..4e31f9d 100644 (file)
@@ -21,7 +21,7 @@ config extern flash_keep
 config internal languages
        
 config internal sauth
-       option sessionpath "/tmp/.lucisessions"
+       option sessionpath "/tmp/luci-sessions"
        option sessiontime 3600
        
 config internal ccache
@@ -29,6 +29,6 @@ config internal ccache
 
 config internal template
        option compiler_mode file
-       option compiledir "/tmp/.lucitplcache"
+       option compiledir "/tmp/luci-templatecache"
                
 config internal themes