trunk: remove underscores in app names (Openwrt ticket #6654)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Mar 2010 23:41:50 +0000 (23:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Mar 2010 23:41:50 +0000 (23:41 +0000)
21 files changed:
applications/luci-hd-idle/Makefile [new file with mode: 0644]
applications/luci-hd-idle/ipkg/postinst [new file with mode: 0644]
applications/luci-hd-idle/luasrc/controller/hd_idle.lua [new file with mode: 0644]
applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua [new file with mode: 0644]
applications/luci-hd-idle/root/etc/uci-defaults/luci-hd_idle [new file with mode: 0644]
applications/luci-hd_idle/Makefile [deleted file]
applications/luci-hd_idle/ipkg/postinst [deleted file]
applications/luci-hd_idle/luasrc/controller/hd_idle.lua [deleted file]
applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua [deleted file]
applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle [deleted file]
applications/luci-mmc-over-gpio/Makefile [new file with mode: 0644]
applications/luci-mmc-over-gpio/ipkg/postinst [new file with mode: 0644]
applications/luci-mmc-over-gpio/luasrc/controller/mmc_over_gpio.lua [new file with mode: 0644]
applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua [new file with mode: 0644]
applications/luci-mmc-over-gpio/root/etc/uci-defaults/luci-mmc_over_gpio [new file with mode: 0644]
applications/luci-mmc_over_gpio/Makefile [deleted file]
applications/luci-mmc_over_gpio/ipkg/postinst [deleted file]
applications/luci-mmc_over_gpio/luasrc/controller/mmc_over_gpio.lua [deleted file]
applications/luci-mmc_over_gpio/luasrc/model/cbi/mmc_over_gpio.lua [deleted file]
applications/luci-mmc_over_gpio/root/etc/uci-defaults/luci-mmc_over_gpio [deleted file]
contrib/package/luci/Makefile

diff --git a/applications/luci-hd-idle/Makefile b/applications/luci-hd-idle/Makefile
new file mode 100644 (file)
index 0000000..d70bb87
--- /dev/null
@@ -0,0 +1,4 @@
+PO = hd_idle
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-hd-idle/ipkg/postinst b/applications/luci-hd-idle/ipkg/postinst
new file mode 100644 (file)
index 0000000..835dc23
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-hd_idle ) && rm -f /etc/uci-defaults/luci-hd_idle
+       /etc/init.d/hd-idle enabled || /etc/init.d/hd-idle enable
+}
diff --git a/applications/luci-hd-idle/luasrc/controller/hd_idle.lua b/applications/luci-hd-idle/luasrc/controller/hd_idle.lua
new file mode 100644 (file)
index 0000000..9d5e5b3
--- /dev/null
@@ -0,0 +1,28 @@
+--[[
+
+LuCI hd-idle
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.hd_idle", package.seeall)
+
+function index()
+       require("luci.i18n")
+       luci.i18n.loadc("hd_idle")
+       if not nixio.fs.access("/etc/config/hd-idle") then
+               return
+       end
+
+       local page = entry({"admin", "services", "hd_idle"}, cbi("hd_idle"), luci.i18n.translate("hd-idle"), 60)
+       page.i18n = "hd_idle"
+       page.dependent = true
+end
diff --git a/applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua b/applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua
new file mode 100644 (file)
index 0000000..82b9eaa
--- /dev/null
@@ -0,0 +1,41 @@
+--[[
+
+LuCI hd-idle
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+require("nixio.fs")
+
+m = Map("hd-idle", translate("hd-idle"), translate("hd-idle is a utility program for spinning-down external disks after a period of idle time."))
+
+s = m:section(TypedSection, "hd-idle", translate("Settings"))
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("enable"))
+
+disk = s:option(Value, "disk", translate("Disk"))
+disk.rmempty = true
+for dev in nixio.fs.glob("/dev/[sh]d[a-z]") do
+       disk:value(nixio.fs.basename(dev))
+end
+
+s:option(Value, "idle_time_interval", translate("Idle-Time")).default = 10
+s.rmempty = true
+unit = s:option(ListValue, "idle_time_unit", translate("Idle-Time unit"))
+unit.default = "minutes"
+unit:value("minutes", "min")
+unit:value("hours", "h")
+unit.rmempty = true
+
+s:option(Flag, "enable_debug", translate("Enable debug"))
+
+return m
diff --git a/applications/luci-hd-idle/root/etc/uci-defaults/luci-hd_idle b/applications/luci-hd-idle/root/etc/uci-defaults/luci-hd_idle
new file mode 100644 (file)
index 0000000..6a37176
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+uci batch <<-EOF
+       add ucitrack hd-idle
+       set ucitrack.@hd-idle[-1].init=hd-idle
+       commit ucitrack
+EOF
diff --git a/applications/luci-hd_idle/Makefile b/applications/luci-hd_idle/Makefile
deleted file mode 100644 (file)
index d70bb87..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = hd_idle
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-hd_idle/ipkg/postinst b/applications/luci-hd_idle/ipkg/postinst
deleted file mode 100644 (file)
index 835dc23..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-hd_idle ) && rm -f /etc/uci-defaults/luci-hd_idle
-       /etc/init.d/hd-idle enabled || /etc/init.d/hd-idle enable
-}
diff --git a/applications/luci-hd_idle/luasrc/controller/hd_idle.lua b/applications/luci-hd_idle/luasrc/controller/hd_idle.lua
deleted file mode 100644 (file)
index 9d5e5b3..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---[[
-
-LuCI hd-idle
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-        http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.hd_idle", package.seeall)
-
-function index()
-       require("luci.i18n")
-       luci.i18n.loadc("hd_idle")
-       if not nixio.fs.access("/etc/config/hd-idle") then
-               return
-       end
-
-       local page = entry({"admin", "services", "hd_idle"}, cbi("hd_idle"), luci.i18n.translate("hd-idle"), 60)
-       page.i18n = "hd_idle"
-       page.dependent = true
-end
diff --git a/applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua b/applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua
deleted file mode 100644 (file)
index 82b9eaa..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
---[[
-
-LuCI hd-idle
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-        http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-require("nixio.fs")
-
-m = Map("hd-idle", translate("hd-idle"), translate("hd-idle is a utility program for spinning-down external disks after a period of idle time."))
-
-s = m:section(TypedSection, "hd-idle", translate("Settings"))
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("enable"))
-
-disk = s:option(Value, "disk", translate("Disk"))
-disk.rmempty = true
-for dev in nixio.fs.glob("/dev/[sh]d[a-z]") do
-       disk:value(nixio.fs.basename(dev))
-end
-
-s:option(Value, "idle_time_interval", translate("Idle-Time")).default = 10
-s.rmempty = true
-unit = s:option(ListValue, "idle_time_unit", translate("Idle-Time unit"))
-unit.default = "minutes"
-unit:value("minutes", "min")
-unit:value("hours", "h")
-unit.rmempty = true
-
-s:option(Flag, "enable_debug", translate("Enable debug"))
-
-return m
diff --git a/applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle b/applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle
deleted file mode 100644 (file)
index 6a37176..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-uci batch <<-EOF
-       add ucitrack hd-idle
-       set ucitrack.@hd-idle[-1].init=hd-idle
-       commit ucitrack
-EOF
diff --git a/applications/luci-mmc-over-gpio/Makefile b/applications/luci-mmc-over-gpio/Makefile
new file mode 100644 (file)
index 0000000..3f031cb
--- /dev/null
@@ -0,0 +1,4 @@
+PO = mmc_over_gpio
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-mmc-over-gpio/ipkg/postinst b/applications/luci-mmc-over-gpio/ipkg/postinst
new file mode 100644 (file)
index 0000000..d88cfb9
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-mmc_over_gpio ) && rm -f /etc/uci-defaults/luci-mmc_over_gpio
+       /etc/init.d/mmc_over_gpio enabled || /etc/init.d/mmc_over_gpio enable
+}
diff --git a/applications/luci-mmc-over-gpio/luasrc/controller/mmc_over_gpio.lua b/applications/luci-mmc-over-gpio/luasrc/controller/mmc_over_gpio.lua
new file mode 100644 (file)
index 0000000..9ee2a9d
--- /dev/null
@@ -0,0 +1,28 @@
+--[[
+
+LuCI mmc_over_gpio
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.mmc_over_gpio", package.seeall)
+
+function index()
+       require("luci.i18n")
+       luci.i18n.loadc("mmc_over_gpio")
+       if not nixio.fs.access("/etc/config/mmc_over_gpio") then
+               return
+       end
+
+       local page = entry({"admin", "system", "mmc_over_gpio"}, cbi("mmc_over_gpio"), luci.i18n.translate("MMC/SD driver configuration"), 60)
+       page.i18n = "mmc_over_gpio"
+       page.dependent = true
+end
diff --git a/applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua b/applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua
new file mode 100644 (file)
index 0000000..04d356c
--- /dev/null
@@ -0,0 +1,41 @@
+--[[
+
+LuCI mmc_over_gpio
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("mmc_over_gpio", translate("MMC/SD driver configuration"),
+       translate("MMC/SD driver configuration"))
+
+s = m:section(TypedSection, "mmc_over_gpio", translate("Settings"))
+s.addremove = true
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("Enable"))
+
+s:option(Value, "name", translate("Name"))
+
+pin = s:option(Value, "DI_pin", translate("DI_pin"))
+for i = 0,7 do pin:value(i) end
+
+pin = s:option(Value, "DO_pin", translate("DO_pin"))
+for i = 0,7 do pin:value(i) end
+
+pin = s:option(Value, "CLK_pin", translate("CLK_pin"))
+for i = 0,7 do pin:value(i) end
+
+pin = s:option(Value, "CS_pin", translate("CS_pin"))
+for i = 0,7 do pin:value(i) end
+
+s:option(Value, "mode", translate("Mode"))
+
+return m
diff --git a/applications/luci-mmc-over-gpio/root/etc/uci-defaults/luci-mmc_over_gpio b/applications/luci-mmc-over-gpio/root/etc/uci-defaults/luci-mmc_over_gpio
new file mode 100644 (file)
index 0000000..3dd22ec
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+uci batch <<-EOF
+       add ucitrack mmc_over_gpio
+       set ucitrack.@mmc_over_gpio[-1].init=mmc_over_gpio
+       commit ucitrack
+EOF
diff --git a/applications/luci-mmc_over_gpio/Makefile b/applications/luci-mmc_over_gpio/Makefile
deleted file mode 100644 (file)
index 3f031cb..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = mmc_over_gpio
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-mmc_over_gpio/ipkg/postinst b/applications/luci-mmc_over_gpio/ipkg/postinst
deleted file mode 100644 (file)
index d88cfb9..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-mmc_over_gpio ) && rm -f /etc/uci-defaults/luci-mmc_over_gpio
-       /etc/init.d/mmc_over_gpio enabled || /etc/init.d/mmc_over_gpio enable
-}
diff --git a/applications/luci-mmc_over_gpio/luasrc/controller/mmc_over_gpio.lua b/applications/luci-mmc_over_gpio/luasrc/controller/mmc_over_gpio.lua
deleted file mode 100644 (file)
index 9ee2a9d..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---[[
-
-LuCI mmc_over_gpio
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-        http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.mmc_over_gpio", package.seeall)
-
-function index()
-       require("luci.i18n")
-       luci.i18n.loadc("mmc_over_gpio")
-       if not nixio.fs.access("/etc/config/mmc_over_gpio") then
-               return
-       end
-
-       local page = entry({"admin", "system", "mmc_over_gpio"}, cbi("mmc_over_gpio"), luci.i18n.translate("MMC/SD driver configuration"), 60)
-       page.i18n = "mmc_over_gpio"
-       page.dependent = true
-end
diff --git a/applications/luci-mmc_over_gpio/luasrc/model/cbi/mmc_over_gpio.lua b/applications/luci-mmc_over_gpio/luasrc/model/cbi/mmc_over_gpio.lua
deleted file mode 100644 (file)
index 04d356c..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
---[[
-
-LuCI mmc_over_gpio
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-        http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-m = Map("mmc_over_gpio", translate("MMC/SD driver configuration"),
-       translate("MMC/SD driver configuration"))
-
-s = m:section(TypedSection, "mmc_over_gpio", translate("Settings"))
-s.addremove = true
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("Enable"))
-
-s:option(Value, "name", translate("Name"))
-
-pin = s:option(Value, "DI_pin", translate("DI_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "DO_pin", translate("DO_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "CLK_pin", translate("CLK_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "CS_pin", translate("CS_pin"))
-for i = 0,7 do pin:value(i) end
-
-s:option(Value, "mode", translate("Mode"))
-
-return m
diff --git a/applications/luci-mmc_over_gpio/root/etc/uci-defaults/luci-mmc_over_gpio b/applications/luci-mmc_over_gpio/root/etc/uci-defaults/luci-mmc_over_gpio
deleted file mode 100644 (file)
index 3dd22ec..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-uci batch <<-EOF
-       add ucitrack mmc_over_gpio
-       set ucitrack.@mmc_over_gpio[-1].init=mmc_over_gpio
-       commit ucitrack
-EOF
index ee2b947..a5ba530 100644 (file)
@@ -646,14 +646,14 @@ define Package/luci-app-samba/install
 endef
 
 
-define Package/luci-app-mmc_over_gpio
+define Package/luci-app-mmc-over-gpio
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc_over_gpio:kmod-mmc-over-gpio
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio
   TITLE:=mmc_over_gpio
 endef
 
-define Package/luci-app-mmc_over_gpio/install
-        $(call Package/luci/install/template,$(1),applications/luci-mmc_over_gpio)
+define Package/luci-app-mmc-over-gpio/install
+        $(call Package/luci/install/template,$(1),applications/luci-mmc-over-gpio)
 endef
 
 
@@ -678,14 +678,14 @@ define Package/luci-app-ushare/install
         $(call Package/luci/install/template,$(1),applications/luci-ushare)
 endef
 
-define Package/luci-app-hd_idle
+define Package/luci-app-hd-idle
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd_idle:hd-idle
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd-idle:hd-idle
   TITLE:=hd-idle
 endef
 
-define Package/luci-app-hd_idle/install
-        $(call Package/luci/install/template,$(1),applications/luci-hd_idle)
+define Package/luci-app-hd-idle/install
+        $(call Package/luci/install/template,$(1),applications/luci-hd-idle)
 endef
 
 define Package/luci-app-tinyproxy
@@ -1112,8 +1112,8 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
        PKG_SELECTED_MODULES+=applications/luci-samba
 endif
-ifneq ($(CONFIG_PACKAGE_luci-app-mmc_over_gpio),)
-        PKG_SELECTED_MODULES+=applications/luci-mmc_over_gpio
+ifneq ($(CONFIG_PACKAGE_luci-app-mmc-over-gpio),)
+        PKG_SELECTED_MODULES+=applications/luci-mmc-over-gpio
 endif
 ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
         PKG_SELECTED_MODULES+=applications/luci-p910nd
@@ -1121,8 +1121,8 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
         PKG_SELECTED_MODULES+=applications/luci-ushare
 endif
-ifneq ($(CONFIG_PACKAGE_luci-app-hd_idle),)
-       PKG_SELECTED_MODULES+=applications/luci-hd_idle
+ifneq ($(CONFIG_PACKAGE_luci-app-hd-idle),)
+       PKG_SELECTED_MODULES+=applications/luci-hd-idle
 endif
 ifneq ($(CONFIG_PACKAGE_luci-app-tinyproxy),)
        PKG_SELECTED_MODULES+=applications/luci-tinyproxy
@@ -1265,10 +1265,10 @@ $(eval $(call BuildPackage,luci-app-upnp))
 $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
-$(eval $(call BuildPackage,luci-app-mmc_over_gpio))
+$(eval $(call BuildPackage,luci-app-mmc-over-gpio))
 $(eval $(call BuildPackage,luci-app-p910nd))
 $(eval $(call BuildPackage,luci-app-ushare))
-$(eval $(call BuildPackage,luci-app-hd_idle))
+$(eval $(call BuildPackage,luci-app-hd-idle))
 $(eval $(call BuildPackage,luci-app-tinyproxy))
 $(eval $(call BuildPackage,luci-app-initmgr))
 $(eval $(call BuildPackage,luci-app-livestats))