build: only consider directories containing a Makefile, fixes compilation crashes...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Jan 2012 19:21:07 +0000 (19:21 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Jan 2012 19:21:07 +0000 (19:21 +0000)
Makefile

index 21c88b2..efccd79 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ include build/config.mk
 MODULES = contrib/* applications/* libs/* modules/* themes/* i18n/*
 
 OS:=$(shell uname)
+MODULES:=$(foreach item,$(wildcard $(MODULES)),$(if $(realpath $(wildcard $(item)/Makefile)),$(item)))
+
 export OS
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean