remove hash.[ch] - i don't think we will need it
authorFelix Fietkau <nbd@openwrt.org>
Sun, 6 Feb 2011 16:20:46 +0000 (17:20 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 6 Feb 2011 16:20:46 +0000 (17:20 +0100)
CMakeLists.txt
hash.c [deleted file]
hash.h [deleted file]

index 699ae95..e5bf46b 100644 (file)
@@ -8,7 +8,7 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-SET(SOURCES avl.c blob.c blobmsg.c hash.c uloop.c usock.c)
+SET(SOURCES avl.c blob.c blobmsg.c uloop.c usock.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
diff --git a/hash.c b/hash.c
deleted file mode 100644 (file)
index 16a0655..0000000
--- a/hash.c
+++ /dev/null
@@ -1,54 +0,0 @@
-#include <stdint.h>
-#include <stdlib.h>
-#include "hash.h"
-
-//-----------------------------------------------------------------------------
-// MurmurHashNeutral2, by Austin Appleby
-
-// Same as MurmurHash2, but endian- and alignment-neutral.
-uint32_t hash_murmur2(const void * key, int len)
-{
-       const unsigned int seed = 0xdeadc0de;
-       const unsigned int m = 0x5bd1e995;
-       const int r = 24;
-
-       unsigned int h = seed ^ len;
-
-       const unsigned char * data = (const unsigned char *)key;
-
-       while(len >= 4)
-       {
-               unsigned int k;
-
-               k  = data[0];
-               k |= data[1] << 8;
-               k |= data[2] << 16;
-               k |= data[3] << 24;
-
-               k *= m;
-               k ^= k >> r;
-               k *= m;
-
-               h *= m;
-               h ^= k;
-
-               data += 4;
-               len -= 4;
-       }
-
-       switch(len)
-       {
-       case 3: h ^= data[2] << 16;
-       case 2: h ^= data[1] << 8;
-       case 1: h ^= data[0];
-               h *= m;
-       };
-
-       h ^= h >> 13;
-       h *= m;
-       h ^= h >> 15;
-
-       return h;
-}
-
-
diff --git a/hash.h b/hash.h
deleted file mode 100644 (file)
index 82b7d3c..0000000
--- a/hash.h
+++ /dev/null
@@ -1,8 +0,0 @@
-#ifndef _HASH_H__
-#define _HASH_H__
-
-#include <stdint.h>
-
-uint32_t hash_murmur2(const void * key, int len);
-
-#endif