add a blobmsg-to-json function
[project/libubox.git] / Makefile
index 3c0399a..996d6a6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,10 +9,10 @@ LIBDIR=$(PREFIX)/lib
 CPPFLAGS=
 
 OS=$(shell uname)
-FILES=blob.c blobmsg.c hash.c uhtbl.c
+FILES=blob.c blobmsg.c hash.c uhtbl.c usock.c uloop.c avl.c
 ifeq ($(OS),Linux)
-  FILES += ucix.c usock.c uloop.c unl.c
-  LIBS += -luci $(LIBNL)
+  FILES += unl.c
+  LIBS += $(LIBNL)
   LDFLAGS_SHARED=-shared -Wl,-soname,$@
   SHLIB_EXT=so
 endif