[package] openssh: add ESSENTIAL_PROCESSES
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Jul 2012 14:58:53 +0000 (14:58 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Jul 2012 14:58:53 +0000 (14:58 +0000)
This adds an ESSENTIAL_PROCESSES shell variable to /etc/init.d/sshd.
The corresponding openwrt patch has the details.

Signed-off-by: Ryan Nowakowski <tubaman@fattuba.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32889 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openssh/Makefile
net/openssh/files/sshd.init

index 331dde8..1b8fcb3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=6.0p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
index ecc44c3..7945439 100644 (file)
@@ -3,9 +3,11 @@
 
 START=50
 STOP=50
+ESSENTIAL_PROCESSES="ssh sshd"
 
 SERVICE_USE_PID=1
 
+
 start() {
        for type in rsa dsa; do {
                # check for keys