rp-pppoe: Fix linkage
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:58:45 +0000 (21:58 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:58:45 +0000 (21:58 +0000)
Do not link against libevent if present on your target. That lib is
completely different from the libevent in rp-pppoe. The lib is part
of the dependencies, so no -L and -l are necessary anyway.

Signed-off-by: Nils Rennebarth <nils.rennebarth@teldat.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39517 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rp-pppoe/patches/110-Makefile.patch [new file with mode: 0644]

diff --git a/net/rp-pppoe/patches/110-Makefile.patch b/net/rp-pppoe/patches/110-Makefile.patch
new file mode 100644 (file)
index 0000000..9dc1c72
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -71,7 +71,7 @@ pppoe-sniff: pppoe-sniff.o if.o common.o
+       @CC@ -o $@ $^ $(LDFLAGS)
+ pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@
+-      @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS) -Llibevent -levent
++      @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS)
+ pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o
+       @CC@ -o $@ $^ $(LDFLAGS)