[packages] aiccu: retry TIC login on nonfatal failures (#10310)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 03:43:40 +0000 (03:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 03:43:40 +0000 (03:43 +0000)
* change the tic_Login() function to indicate fatal vs. nonfatal login errors
* retry tic_Login() on nonfatal failures, wait at least 10 seconds per retry
* increase delay by 10 seconds per try until the maximum of 120 seconds is reached
* move aiccu start command into background as it can take a long time to deamonize due to retries, blocking subsequent init scripts
* remove hotplug script for aiccu, the running instances should recover themselves if time and connectivity become available

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28796 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/aiccu/Makefile
ipv6/aiccu/files/aiccu.hotplug [deleted file]
ipv6/aiccu/files/aiccu.init

index b2c4f22..c568115 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
@@ -50,8 +50,6 @@ define Package/aiccu/install
        $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/config/aiccu
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/iface/30-aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))
diff --git a/ipv6/aiccu/files/aiccu.hotplug b/ipv6/aiccu/files/aiccu.hotplug
deleted file mode 100644 (file)
index 5830415..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu restart
index b29310e..fae1ae5 100644 (file)
@@ -47,7 +47,7 @@ start_instance() {
        echo -e "$args" > "$CFGFILE"
 
        config_get_bool enabled "$cfg" enabled '1'
-       [ "$enabled" -gt 0 ] && aiccu start "$CFGFILE"
+       [ "$enabled" -gt 0 ] && aiccu start "$CFGFILE" &
 }
 
 stop_instance() {