add quotes to TARGET_CC and TARGET_CROSS to help with distcc and ccache (yet again)
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 03:33:37 +0000 (03:33 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 03:33:37 +0000 (03:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4431 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/iftop/Makefile
net/igmpproxy/Makefile
net/irssi/Makefile
net/l2tpd/Makefile
net/l2tpns/Makefile
net/maradns/Makefile
utils/logrotate/Makefile

index 589dd21..44501c7 100644 (file)
@@ -41,7 +41,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
 endef
index 3cda6fc..06620e7 100644 (file)
@@ -29,7 +29,7 @@ only IGMP signalling (Internet Group Management Protocol).\\\
 endef
 
 define Build/Compile   
-       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/src
+       $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/src
 endef
 
 
index 42a448c..7613a42 100644 (file)
@@ -47,7 +47,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/irssi/install   
index a3441ec..f478e72 100644 (file)
@@ -42,7 +42,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION"
 endef
 
index 2fc0dee..d9498bf 100644 (file)
@@ -41,8 +41,8 @@ endef
        
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               LD=$(TARGET_CC) \
+               CC="$(TARGET_CC) \
+               LD=$(TARGET_CC)" \
                OPTIM="$(TARGET_CFLAGS)" \
                DESTDIR=$(PKG_INSTALL_DIR) \
                STAGING_DIR=$(STAGING_DIR) \
index d019f94..f06f0ed 100644 (file)
@@ -45,7 +45,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CFLAGS="$(TARGET_CFLAGS)" \
                FLAGS="$(TARGET_CFLAGS)" \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                HOSTCC="$(HOSTCC)"
        mkdir -p $(PKG_INSTALL_DIR)/usr/{bin,sbin}
        mkdir -p $(PKG_INSTALL_DIR)/usr/man/man{1,5,8}
index 57f978b..1bf28a2 100644 (file)
@@ -40,7 +40,7 @@ define Build/Compile
        make -C ${PKG_BUILD_DIR} \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               CC=$(TARGET_CC) logrotate
+               CC="$(TARGET_CC)" logrotate
 endef
 
 define Package/logrotate/install