fix a dependency problem
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jan 2008 22:05:03 +0000 (22:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jan 2008 22:05:03 +0000 (22:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10241 3c298f89-4303-0410-b956-a3cf2f4a3e73

XOrg/app/xinit/Makefile

index dcdecb8..1656ca4 100644 (file)
@@ -16,18 +16,13 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
-ifneq (xinit,xinit)
-_DEPEND+=xorg-server-essentials
-endif
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xinit
   SECTION:=xorg-app
   CATEGORY:=Xorg
   SUBMENU:=app
-  DEPENDS:=${_DEPEND} @DISPLAY_SUPPORT
+  DEPENDS:=libX11 @DISPLAY_SUPPORT
   TITLE:=xinit
   URL:=http://xorg.freedesktop.org/
 endef