[packages] dsl-qos-queue: revert [22489] (backfire has no shared libipq, static libip...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Aug 2010 17:36:13 +0000 (17:36 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Aug 2010 17:36:13 +0000 (17:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22583 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/dsl-qos-queue/Makefile

index e3d0739..99a2d3e 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt +libipq @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
+  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
@@ -34,7 +34,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.so \
+               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.a \
                all \
        )
 endef