python packages cleanup, add some missing deps
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Aug 2008 16:12:31 +0000 (16:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Aug 2008 16:12:31 +0000 (16:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12271 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
lang/egenix-mx/Makefile
lang/gst-python/Makefile
lang/kid/Makefile
lang/logilab-astng/Makefile
lang/logilab-common/Makefile
lang/psycopg/Makefile
lang/pybluez/Makefile
lang/pyevent/Makefile
lang/pymysql/Makefile
lang/pypcap/Makefile
lang/pysqlite/Makefile
lang/twisted/Makefile
lang/yapsnmp/Makefile

index 7e5001b..35bdcf0 100644 (file)
@@ -21,9 +21,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-egenix-mx
   SUBMENU:=Python
@@ -40,6 +37,7 @@ define Package/python-egenix-mx/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --build-lib="foo", \
                BASECFLAGS="$(TARGET_CFLAGS)" \
index e2e6261..61af262 100644 (file)
@@ -26,7 +26,7 @@ define Package/gst-python
   CATEGORY:=Languages
   TITLE:=python bindings for dbus
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:=+gstreamer +gst-plugins-base @BROKEN
+  DEPENDS:=+gstreamer +gst-plugins-base +python-gtk @BROKEN
 endef
 
 define Package/gst-python/description
index 0e93eee..ff15a54 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-kid
   SUBMENU:=Python
@@ -44,6 +41,7 @@ define PyPackage/python-kid/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 7d018e0..eec67a8 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE_URL:=ftp://ftp.logilab.fr/pub/astng/
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/logilab-astng
   SUBMENU:=Python
@@ -33,6 +30,7 @@ define Package/logilab-astng/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 5e69a58..26c31ae 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE_URL:=ftp://ftp.logilab.fr/pub/common/
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/logilab-common
   SUBMENU:=Python
@@ -33,6 +30,7 @@ define Package/logilab-common/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 288b754..f406056 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-psycopg
   SUBMENU:=Python
@@ -45,6 +42,7 @@ CONFIGURE_ARGS += \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)"
 endef
index 3abfef0..8eb6459 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-bluez
   SUBMENU:=Python
@@ -41,7 +38,8 @@ CONFIGURE_ARGS += \
        --with-python="$(PYTHON)" \
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
 endef
index 01d93a4..0b2403e 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-event
   SUBMENU:=Python
@@ -38,7 +35,8 @@ define PyPackage/python-event/filespec
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                LIBEVENT_HOME="$(STAGING_DIR)/usr/lib" \
        )
index c0b6701..8b0486a 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-mysql
   SUBMENU:=Python
@@ -45,6 +42,7 @@ define PyPackage/python-mysql/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 23d6645..aa3c0e1 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -38,6 +35,7 @@ define PyPackage/python-pcap/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                PCAP_HOME="$(STAGING_DIR)/usr" \
index b1629fb..ee74d7f 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-sqlite
  SUBMENU:=Python
@@ -44,6 +41,7 @@ define PyPackage/python-sqlite/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 03a5576..4acaac4 100644 (file)
@@ -21,9 +21,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/twisted/default
   SUBMENU:=Python
@@ -218,6 +215,7 @@ define PyPackage/zope-interface/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \
index ce597c1..e60d11d 100644 (file)
@@ -22,9 +22,6 @@ PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-yapsnmp
   SUBMENU:=Python
@@ -58,6 +55,7 @@ CONFIGURE_VARS += \
        ac_cv_prog_SWIG="echo MISSING SWIG" \
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INCLUDES="-I$(PYTHON_INC_DIR)" \
                SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \