libjpeg-turbo: add package for test utils, move appropriate targets there
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Feb 2013 09:59:34 +0000 (09:59 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Feb 2013 09:59:34 +0000 (09:59 +0000)
Trying to figure out where jpeggut came from, found a) that it was a
typo and b) that it was renamed in r643 from jpegut to tjunittest.  In
the same revision, jpegtest became tjbench, and later in r733, jcstest
was added to test jpeg color space extentions.  Since these tools will
only be desirable for testing, added a new package libjpeg-turbo-tests
to provide these utilities.  The utilities needed libturbojpeg, so
added what had been a commented out library to the new package.

The libturbojpeg are currently commented out in InstallDev as well.
If external packages begin to rely on libturbojpeg functions for some
reason, the library should be added back.

Signed-off-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35655 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libjpeg-turbo/Makefile

index 9ae15a6..546bf9b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libjpeg-turbo
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/libjpeg-turbo
@@ -43,6 +43,14 @@ define Package/jpeg-tools
   TITLE+= manipulation tools
 endef
 
+define Package/libjpeg-turbo-tests
+  $(call Package/libjpeg-turbo/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libjpeg-turbo
+  TITLE+= testing utilities
+endef
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -69,17 +77,25 @@ endef
 define Package/libjpeg-turbo/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/.libs/libjpeg.{a,so*} $(1)/usr/lib/
-#      $(CP) $(PKG_BUILD_DIR)/.libs/libturbojpeg.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/jpeg-tools/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/{c,d}jpeg $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/jpeg{tran,gut} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/jpegtran $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/{rd,wr}jpgcom $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/jpgtest $(1)/usr/bin/
+endef
+
+define Package/libjpeg-turbo-tests/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/tjbench $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/tjunittest $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/jcstest $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/.libs/libturbojpeg.{a,so*} $(1)/usr/lib/
 endef
 
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,libjpeg-turbo))
 $(eval $(call BuildPackage,jpeg-tools))
+$(eval $(call BuildPackage,libjpeg-turbo-tests))