[packages] rp-pppoe: upgrade to version 3.11
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Feb 2013 01:03:41 +0000 (01:03 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Feb 2013 01:03:41 +0000 (01:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35647 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rp-pppoe/Makefile
net/rp-pppoe/patches/100-configure.patch

index 9f96f90..abb921f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-pppoe
-PKG_VERSION:=3.10
-PKG_RELEASE:=2
+PKG_VERSION:=3.11
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
-PKG_MD5SUM:=d58a13cc4185bca6121a606ff456dec0
+PKG_MD5SUM:=13b5900c56bd602df6cc526e5e520722
 
 PKG_BUILD_DEPENDS:=ppp
 
index 784ff73..62e9222 100644 (file)
@@ -1,37 +1,35 @@
 --- a/src/configure
 +++ b/src/configure
-@@ -3610,7 +3610,7 @@ _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h.  */
--#include<sys/socket.h>
-+#include <sys/socket.h>
- #include <$ac_header>
- _ACEOF
-@@ -3669,11 +3669,11 @@ cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h.  */
+@@ -3661,7 +3661,7 @@ done
  
+ for ac_header in linux/if.h
+ do :
+-  ac_fn_c_check_header_compile "$LINENO" "linux/if.h" "ac_cv_header_linux_if_h" "#include<sys/socket.h>
++  ac_fn_c_check_header_compile "$LINENO" "linux/if.h" "ac_cv_header_linux_if_h" "#include <sys/socket.h>
+ "
+ if test "x$ac_cv_header_linux_if_h" = x""yes; then :
+   cat >>confdefs.h <<_ACEOF
+@@ -3675,10 +3675,10 @@ done
+ for ac_header in linux/if_pppox.h
+ do :
+   ac_fn_c_check_header_compile "$LINENO" "linux/if_pppox.h" "ac_cv_header_linux_if_pppox_h" "
 -#include<sys/socket.h>
 -#include<net/ethernet.h>
 -#include<linux/if.h>
 -#include<linux/in.h>
--
 +#include <sys/socket.h>
 +#include <net/ethernet.h>
 +#include <linux/if.h>
 +#include <linux/in.h>
-+#include <linux/in6.h>
  
- #include <$ac_header>
- _ACEOF
-@@ -6272,7 +6272,7 @@ esac
- { echo "$as_me:$LINENO: checking packing order of bit fields" >&5
- echo $ECHO_N "checking packing order of bit fields... $ECHO_C" >&6; }
- if test "$cross_compiling" = yes; then
+ "
+ if test "x$ac_cv_header_linux_if_pppox_h" = x""yes; then :
+@@ -4611,7 +4611,7 @@ esac
+ $as_echo_n "checking packing order of bit fields... " >&6; }
+ if test "${rpppoe_cv_pack_bitfields+set}" != set ; then
+ if test "$cross_compiling" = yes; then :
 -  $ECHO "no defaults for cross-compiling"; exit 0
 +  rpppoe_cv_pack_bitfields="$ac_cv_pack_bitfields"
  else
-   cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h.  */
+   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h.  */